p PatchFirst

CVE-2020-15169

CVE-2020-15169 · XSS in Action View

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

In Action View before versions 5.2.4.4 and 6.0.3.3 there is a potential Cross-Site Scripting (XSS) vulnerability in Action View's translation helpers. Views that allow the user to control the default (not found) value of the `t` and `translate` helpers could be susceptible to XSS attacks. When an HTML-unsafe string is passed as the default for a missing translation key named html or ending in _html, the default string is incorrectly marked as HTML-safe and not escaped. This is patched in versions 6.0.3.3 and 5.2.4.4. A workaround without upgrading is proposed in the source advisory.

CVSS 5.4 · Media · EPSS 2,4% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • actionview

    Versiones
    • < 5.2.4.4: Afectada
    • >= 6.0.0.0, < 6.0.3.3: Afectada

    Sin corrección publicada

  • rails Debian:12

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2:6.0.3.3+dfsg-1

    Actualiza a 2:6.0.3.3+dfsg-1

  • rails Debian:13

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2:6.0.3.3+dfsg-1

    Actualiza a 2:6.0.3.3+dfsg-1

  • rails Debian:14

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2:6.0.3.3+dfsg-1

    Actualiza a 2:6.0.3.3+dfsg-1

  • rails Ubuntu:Pro:16.04:LTS

    Versiones
    • 2:4.1.10-1
    • 2:4.2.5-1
    • 2:4.2.5.1-1
    • 2:4.2.5.2-2
    • 2:4.2.6-1
    • 2:4.2.6-1ubuntu0.1~esm1
    • 2:4.2.6-1ubuntu0.1~esm2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • rails Ubuntu:Pro:18.04:LTS

    Versiones
    • 2:4.2.9-2
    • 2:4.2.9-4
    • 2:4.2.10-0ubuntu4
    • 2:4.2.10-0ubuntu4+esm1
    • 2:4.2.10-0ubuntu4+esm2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • rails Ubuntu:Pro:20.04:LTS

    Versiones
    • 2:5.2.2.1+dfsg-1ubuntu1
    • 2:5.2.3+dfsg-3
    • 2:5.2.3+dfsg-3ubuntu0.1~esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • rails Ubuntu:Pro:22.04:LTS

    Versiones
    • 2:6.0.3.7+dfsg-2
    • 2:6.1.4.1+dfsg-8ubuntu2
    • 2:6.1.4.1+dfsg-8ubuntu2+esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • rails Ubuntu:24.04:LTS

    Versiones
    • 2:6.1.7.3+dfsg-2build1
    • 2:6.1.7.3+dfsg-3
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • rails Ubuntu:25.10

    Versiones
    • 2:6.1.7.3+dfsg-7
    • 2:7.2.2.1+dfsg-7
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • rails Ubuntu:26.10

    Versiones
    • 2:7.2.3+dfsg-2
    • 2:7.2.3.2+dfsg-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • rails Ubuntu:26.04:LTS

    Versiones
    • 2:7.2.2.1+dfsg-7
    • 2:7.2.2.2+dfsg-2
    • 2:7.2.3+dfsg-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →