CVE-2020-15169
CVE-2020-15169 · XSS in Action View
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
In Action View before versions 5.2.4.4 and 6.0.3.3 there is a potential Cross-Site Scripting (XSS) vulnerability in Action View's translation helpers. Views that allow the user to control the default (not found) value of the `t` and `translate` helpers could be susceptible to XSS attacks. When an HTML-unsafe string is passed as the default for a missing translation key named html or ending in _html, the default string is incorrectly marked as HTML-safe and not escaped. This is patched in versions 6.0.3.3 and 5.2.4.4. A workaround without upgrading is proposed in the source advisory.
CVSS 5.4 · Moyenne · EPSS 2,4% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
actionview
- Versions du logiciel
- < 5.2.4.4: Concernée
- >= 6.0.0.0, < 6.0.3.3: Concernée
Aucun correctif publié
rails Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 2:6.0.3.3+dfsg-1
Mettez à jour vers 2:6.0.3.3+dfsg-1
rails Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 2:6.0.3.3+dfsg-1
Mettez à jour vers 2:6.0.3.3+dfsg-1
rails Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 2:6.0.3.3+dfsg-1
Mettez à jour vers 2:6.0.3.3+dfsg-1
rails Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 2:4.1.10-1
- 2:4.2.5-1
- 2:4.2.5.1-1
- 2:4.2.5.2-2
- 2:4.2.6-1
- 2:4.2.6-1ubuntu0.1~esm1
- 2:4.2.6-1ubuntu0.1~esm2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
rails Ubuntu:Pro:18.04:LTS
- Versions du logiciel
- 2:4.2.9-2
- 2:4.2.9-4
- 2:4.2.10-0ubuntu4
- 2:4.2.10-0ubuntu4+esm1
- 2:4.2.10-0ubuntu4+esm2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
rails Ubuntu:Pro:20.04:LTS
- Versions du logiciel
- 2:5.2.2.1+dfsg-1ubuntu1
- 2:5.2.3+dfsg-3
- 2:5.2.3+dfsg-3ubuntu0.1~esm1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
rails Ubuntu:Pro:22.04:LTS
- Versions du logiciel
- 2:6.0.3.7+dfsg-2
- 2:6.1.4.1+dfsg-8ubuntu2
- 2:6.1.4.1+dfsg-8ubuntu2+esm1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
rails Ubuntu:24.04:LTS
- Versions du logiciel
- 2:6.1.7.3+dfsg-2build1
- 2:6.1.7.3+dfsg-3
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
rails Ubuntu:25.10
- Versions du logiciel
- 2:6.1.7.3+dfsg-7
- 2:7.2.2.1+dfsg-7
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
rails Ubuntu:26.10
- Versions du logiciel
- 2:7.2.3+dfsg-2
- 2:7.2.3.2+dfsg-2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
rails Ubuntu:26.04:LTS
- Versions du logiciel
- 2:7.2.2.1+dfsg-7
- 2:7.2.2.2+dfsg-2
- 2:7.2.3+dfsg-2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
Sources originales
- https://github.com/rails/rails/security/advisories/GHSA-cfjv-5498-mph5
- https://www.debian.org/security/2020/dsa-4766
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/XJ7NUWXAEVRQCROIIBV4C6WXO6IR3KSB/
- https://lists.debian.org/debian-lts-announce/2020/10/msg00015.html
- https://nvd.nist.gov/vuln/detail/CVE-2020-15169