CVE-2020-15210
CVE-2020-15210 · Segmentation fault in tensorflow-lite
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
In tensorflow-lite before versions 1.15.4, 2.0.3, 2.1.2, 2.2.1 and 2.3.1, if a TFLite saved model uses the same tensor as both input and output of an operator, then, depending on the operator, we can observe a segmentation fault or just memory corruption. We have patched the issue in d58c96946b and will release patch releases for all versions between 1.15 and 2.3. We recommend users to upgrade to TensorFlow 1.15.4, 2.0.3, 2.1.2, 2.2.1, or 2.3.1.
CVSS 6.5 · Media · EPSS 0,7% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: python
Productos y versiones afectados
tensorflow
- Versiones
- < 1.15.4: Afectada
- >= 2.0.0, < 2.0.3: Afectada
- >= 2.1.0, < 2.1.2: Afectada
- >= 2.2.0, < 2.2.1: Afectada
- >= 2.3.0, < 2.3.1: Afectada
Sin corrección publicada
tensorflow PyPI
- Versiones
- 0.12.0
- 0.12.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.10.0
- 1.10.1
- 1.11.0
- 1.12.0
- 1.12.2
- 1.12.3
- 1.13.1
- 1.13.2
- 1.14.0
- 1.15.0
- 1.15.2
- 1.15.3
- 1.2.0
- 1.2.1
- 1.3.0
- 1.4.0
- 1.4.1
- 1.5.0
- 1.5.1
- 1.6.0
- 1.7.0
- 1.7.1
- 1.8.0
- 1.9.0
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.15.4
Actualiza a 1.15.4
tensorflow PyPI
- Versiones
- 2.0.0
- 2.0.1
- 2.0.2
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 2.0.0, < 2.0.3
Actualiza a 2.0.3
tensorflow PyPI
- Versiones
- 2.1.0
- 2.1.1
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 2.1.0, < 2.1.2
Actualiza a 2.1.2
tensorflow PyPI
- Versiones
- 2.2.0
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 2.2.0, < 2.2.1
Actualiza a 2.2.1
tensorflow PyPI
- Versiones
- 2.3.0
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 2.3.0, < 2.3.1
Actualiza a 2.3.1
tensorflow-cpu PyPI
- Versiones
- 1.15.0
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.15.4
Actualiza a 1.15.4
tensorflow-cpu PyPI
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 2.0.0, < 2.0.3
Actualiza a 2.0.3
tensorflow-cpu PyPI
- Versiones
- 2.1.0
- 2.1.1
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 2.1.0, < 2.1.2
Actualiza a 2.1.2
tensorflow-cpu PyPI
- Versiones
- 2.2.0
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 2.2.0, < 2.2.1
Actualiza a 2.2.1
tensorflow-gpu PyPI
- Versiones
- 0.12.0
- 0.12.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.10.0
- 1.10.1
- 1.11.0
- 1.12.0
- 1.12.2
- 1.12.3
- 1.13.1
- 1.13.2
- 1.14.0
- 1.15.0
- 1.15.2
- 1.15.3
- 1.2.0
- 1.2.1
- 1.3.0
- 1.4.0
- 1.4.1
- 1.5.0
- 1.5.1
- 1.6.0
- 1.7.0
- 1.7.1
- 1.8.0
- 1.9.0
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.15.4
Actualiza a 1.15.4
tensorflow-gpu PyPI
- Versiones
- 2.0.0
- 2.0.1
- 2.0.2
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 2.0.0, < 2.0.3
Actualiza a 2.0.3
tensorflow-gpu PyPI
- Versiones
- 2.1.0
- 2.1.1
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 2.1.0, < 2.1.2
Actualiza a 2.1.2
tensorflow-gpu PyPI
- Versiones
- 2.2.0
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 2.2.0, < 2.2.1
Actualiza a 2.2.1
tensorflow-cpu PyPI
- Versiones
- 2.3.0
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 2.3.0, < 2.3.1
Actualiza a 2.3.1
tensorflow-gpu PyPI
- Versiones
- 2.3.0
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 2.3.0, < 2.3.1
Actualiza a 2.3.1
tensorflow PyPI
- Versiones
- 0.12.0rc0
- 0.12.0rc1
- 0.12.0
- 0.12.1
- 1.0.0
- 1.0.1
- 1.1.0rc0
- 1.1.0rc1
- 1.1.0rc2
- 1.1.0
- 1.2.0rc0
- 1.2.0rc1
- 1.2.0rc2
- 1.2.0
- 1.2.1
- 1.3.0rc0
- 1.3.0rc1
- 1.3.0rc2
- 1.3.0
- 1.4.0rc0
- 1.4.0rc1
- 1.4.0
- 1.4.1
- 1.5.0rc0
- 1.5.0rc1
- 1.5.0
- 1.5.1
- 1.6.0rc0
- 1.6.0rc1
- 1.6.0
- 1.7.0rc0
- 1.7.0rc1
- 1.7.0
- 1.7.1
- 1.8.0rc0
- 1.8.0rc1
- 1.8.0
- 1.9.0rc0
- 1.9.0rc1
- 1.9.0rc2
- 1.9.0
- 1.10.0rc0
- 1.10.0rc1
- 1.10.0
- 1.10.1
- 1.11.0rc0
- 1.11.0rc1
- 1.11.0rc2
- 1.11.0
- 1.12.0rc0
- 1.12.0rc1
- 1.12.0rc2
- 1.12.0
- 1.12.2
- 1.12.3
- 1.13.0rc0
- 1.13.0rc1
- 1.13.0rc2
- 1.13.1
- 1.13.2
- 1.14.0rc0
- 1.14.0rc1
- 1.14.0
- 1.15.0rc0
- 1.15.0rc1
- 1.15.0rc2
- 1.15.0rc3
- 1.15.0
- 1.15.2
- 1.15.3
- 2.0.0
- 2.0.1
- 2.0.2
- 2.1.0
- 2.1.1
- 2.2.0
- 2.3.0
- Intervalos de versiones afectados
- GIT: < d58c96946b2880991d63d1dacacb32f0a4dfa453
- ECOSYSTEM: < 1.15.4 ∪ ≥ 2.0.0, < 2.0.3 ∪ ≥ 2.1.0, < 2.1.2 ∪ ≥ 2.2.0, < 2.2.1 ∪ ≥ 2.3.0, < 2.3.1
Actualiza a 1.15.4; Actualiza a 2.0.3; Actualiza a 2.1.2; Actualiza a 2.2.1; Actualiza a 2.3.1
tensorflow-cpu PyPI
- Versiones
- 1.15.0
- 2.1.0
- 2.1.1
- 2.2.0
- 2.3.0
- Intervalos de versiones afectados
- GIT: < d58c96946b2880991d63d1dacacb32f0a4dfa453
- ECOSYSTEM: < 1.15.4 ∪ ≥ 2.0.0, < 2.0.3 ∪ ≥ 2.1.0, < 2.1.2 ∪ ≥ 2.2.0, < 2.2.1 ∪ ≥ 2.3.0, < 2.3.1
Actualiza a 1.15.4; Actualiza a 2.0.3; Actualiza a 2.1.2; Actualiza a 2.2.1; Actualiza a 2.3.1
tensorflow-gpu PyPI
- Versiones
- 0.12.0
- 0.12.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.10.0
- 1.10.1
- 1.11.0
- 1.12.0
- 1.12.2
- 1.12.3
- 1.13.1
- 1.13.2
- 1.14.0
- 1.15.0
- 1.15.2
- 1.15.3
- 1.2.0
- 1.2.1
- 1.3.0
- 1.4.0
- 1.4.1
- 1.5.0
- 1.5.1
- 1.6.0
- 1.7.0
- 1.7.1
- 1.8.0
- 1.9.0
- 2.0.0
- 2.0.1
- 2.0.2
- 2.1.0
- 2.1.1
- 2.2.0
- 2.3.0
- Intervalos de versiones afectados
- GIT: < d58c96946b2880991d63d1dacacb32f0a4dfa453
- ECOSYSTEM: < 1.15.4 ∪ ≥ 2.0.0, < 2.0.3 ∪ ≥ 2.1.0, < 2.1.2 ∪ ≥ 2.2.0, < 2.2.1 ∪ ≥ 2.3.0, < 2.3.1
Actualiza a 1.15.4; Actualiza a 2.0.3; Actualiza a 2.1.2; Actualiza a 2.2.1; Actualiza a 2.3.1
Fuentes originales
- https://github.com/tensorflow/tensorflow/releases/tag/v2.3.1
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-x9j7-x98r-r4w2
- https://github.com/tensorflow/tensorflow/commit/d58c96946b2880991d63d1dacacb32f0a4dfa453
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00065.html
- https://nvd.nist.gov/vuln/detail/CVE-2020-15210