CVE-2020-15210
CVE-2020-15210 · Segmentation fault in tensorflow-lite
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
In tensorflow-lite before versions 1.15.4, 2.0.3, 2.1.2, 2.2.1 and 2.3.1, if a TFLite saved model uses the same tensor as both input and output of an operator, then, depending on the operator, we can observe a segmentation fault or just memory corruption. We have patched the issue in d58c96946b and will release patch releases for all versions between 1.15 and 2.3. We recommend users to upgrade to TensorFlow 1.15.4, 2.0.3, 2.1.2, 2.2.1, or 2.3.1.
CVSS 6.5 · Mittel · EPSS 0,7% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: python
Betroffene Produkte und Versionen
tensorflow
- Softwareversionen
- < 1.15.4: Betroffen
- >= 2.0.0, < 2.0.3: Betroffen
- >= 2.1.0, < 2.1.2: Betroffen
- >= 2.2.0, < 2.2.1: Betroffen
- >= 2.3.0, < 2.3.1: Betroffen
Keine Korrektur veröffentlicht
tensorflow PyPI
- Softwareversionen
- 0.12.0
- 0.12.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.10.0
- 1.10.1
- 1.11.0
- 1.12.0
- 1.12.2
- 1.12.3
- 1.13.1
- 1.13.2
- 1.14.0
- 1.15.0
- 1.15.2
- 1.15.3
- 1.2.0
- 1.2.1
- 1.3.0
- 1.4.0
- 1.4.1
- 1.5.0
- 1.5.1
- 1.6.0
- 1.7.0
- 1.7.1
- 1.8.0
- 1.9.0
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.15.4
Auf 1.15.4 aktualisieren
tensorflow PyPI
- Softwareversionen
- 2.0.0
- 2.0.1
- 2.0.2
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.0.0, < 2.0.3
Auf 2.0.3 aktualisieren
tensorflow PyPI
- Softwareversionen
- 2.1.0
- 2.1.1
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.1.0, < 2.1.2
Auf 2.1.2 aktualisieren
tensorflow PyPI
- Softwareversionen
- 2.2.0
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.2.0, < 2.2.1
Auf 2.2.1 aktualisieren
tensorflow PyPI
- Softwareversionen
- 2.3.0
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.3.0, < 2.3.1
Auf 2.3.1 aktualisieren
tensorflow-cpu PyPI
- Softwareversionen
- 1.15.0
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.15.4
Auf 1.15.4 aktualisieren
tensorflow-cpu PyPI
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.0.0, < 2.0.3
Auf 2.0.3 aktualisieren
tensorflow-cpu PyPI
- Softwareversionen
- 2.1.0
- 2.1.1
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.1.0, < 2.1.2
Auf 2.1.2 aktualisieren
tensorflow-cpu PyPI
- Softwareversionen
- 2.2.0
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.2.0, < 2.2.1
Auf 2.2.1 aktualisieren
tensorflow-gpu PyPI
- Softwareversionen
- 0.12.0
- 0.12.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.10.0
- 1.10.1
- 1.11.0
- 1.12.0
- 1.12.2
- 1.12.3
- 1.13.1
- 1.13.2
- 1.14.0
- 1.15.0
- 1.15.2
- 1.15.3
- 1.2.0
- 1.2.1
- 1.3.0
- 1.4.0
- 1.4.1
- 1.5.0
- 1.5.1
- 1.6.0
- 1.7.0
- 1.7.1
- 1.8.0
- 1.9.0
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1.15.4
Auf 1.15.4 aktualisieren
tensorflow-gpu PyPI
- Softwareversionen
- 2.0.0
- 2.0.1
- 2.0.2
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.0.0, < 2.0.3
Auf 2.0.3 aktualisieren
tensorflow-gpu PyPI
- Softwareversionen
- 2.1.0
- 2.1.1
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.1.0, < 2.1.2
Auf 2.1.2 aktualisieren
tensorflow-gpu PyPI
- Softwareversionen
- 2.2.0
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.2.0, < 2.2.1
Auf 2.2.1 aktualisieren
tensorflow-cpu PyPI
- Softwareversionen
- 2.3.0
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.3.0, < 2.3.1
Auf 2.3.1 aktualisieren
tensorflow-gpu PyPI
- Softwareversionen
- 2.3.0
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.3.0, < 2.3.1
Auf 2.3.1 aktualisieren
tensorflow PyPI
- Softwareversionen
- 0.12.0rc0
- 0.12.0rc1
- 0.12.0
- 0.12.1
- 1.0.0
- 1.0.1
- 1.1.0rc0
- 1.1.0rc1
- 1.1.0rc2
- 1.1.0
- 1.2.0rc0
- 1.2.0rc1
- 1.2.0rc2
- 1.2.0
- 1.2.1
- 1.3.0rc0
- 1.3.0rc1
- 1.3.0rc2
- 1.3.0
- 1.4.0rc0
- 1.4.0rc1
- 1.4.0
- 1.4.1
- 1.5.0rc0
- 1.5.0rc1
- 1.5.0
- 1.5.1
- 1.6.0rc0
- 1.6.0rc1
- 1.6.0
- 1.7.0rc0
- 1.7.0rc1
- 1.7.0
- 1.7.1
- 1.8.0rc0
- 1.8.0rc1
- 1.8.0
- 1.9.0rc0
- 1.9.0rc1
- 1.9.0rc2
- 1.9.0
- 1.10.0rc0
- 1.10.0rc1
- 1.10.0
- 1.10.1
- 1.11.0rc0
- 1.11.0rc1
- 1.11.0rc2
- 1.11.0
- 1.12.0rc0
- 1.12.0rc1
- 1.12.0rc2
- 1.12.0
- 1.12.2
- 1.12.3
- 1.13.0rc0
- 1.13.0rc1
- 1.13.0rc2
- 1.13.1
- 1.13.2
- 1.14.0rc0
- 1.14.0rc1
- 1.14.0
- 1.15.0rc0
- 1.15.0rc1
- 1.15.0rc2
- 1.15.0rc3
- 1.15.0
- 1.15.2
- 1.15.3
- 2.0.0
- 2.0.1
- 2.0.2
- 2.1.0
- 2.1.1
- 2.2.0
- 2.3.0
- Betroffene Versionsbereiche
- GIT: < d58c96946b2880991d63d1dacacb32f0a4dfa453
- ECOSYSTEM: < 1.15.4 ∪ ≥ 2.0.0, < 2.0.3 ∪ ≥ 2.1.0, < 2.1.2 ∪ ≥ 2.2.0, < 2.2.1 ∪ ≥ 2.3.0, < 2.3.1
Auf 1.15.4 aktualisieren; Auf 2.0.3 aktualisieren; Auf 2.1.2 aktualisieren; Auf 2.2.1 aktualisieren; Auf 2.3.1 aktualisieren
tensorflow-cpu PyPI
- Softwareversionen
- 1.15.0
- 2.1.0
- 2.1.1
- 2.2.0
- 2.3.0
- Betroffene Versionsbereiche
- GIT: < d58c96946b2880991d63d1dacacb32f0a4dfa453
- ECOSYSTEM: < 1.15.4 ∪ ≥ 2.0.0, < 2.0.3 ∪ ≥ 2.1.0, < 2.1.2 ∪ ≥ 2.2.0, < 2.2.1 ∪ ≥ 2.3.0, < 2.3.1
Auf 1.15.4 aktualisieren; Auf 2.0.3 aktualisieren; Auf 2.1.2 aktualisieren; Auf 2.2.1 aktualisieren; Auf 2.3.1 aktualisieren
tensorflow-gpu PyPI
- Softwareversionen
- 0.12.0
- 0.12.1
- 1.0.0
- 1.0.1
- 1.1.0
- 1.10.0
- 1.10.1
- 1.11.0
- 1.12.0
- 1.12.2
- 1.12.3
- 1.13.1
- 1.13.2
- 1.14.0
- 1.15.0
- 1.15.2
- 1.15.3
- 1.2.0
- 1.2.1
- 1.3.0
- 1.4.0
- 1.4.1
- 1.5.0
- 1.5.1
- 1.6.0
- 1.7.0
- 1.7.1
- 1.8.0
- 1.9.0
- 2.0.0
- 2.0.1
- 2.0.2
- 2.1.0
- 2.1.1
- 2.2.0
- 2.3.0
- Betroffene Versionsbereiche
- GIT: < d58c96946b2880991d63d1dacacb32f0a4dfa453
- ECOSYSTEM: < 1.15.4 ∪ ≥ 2.0.0, < 2.0.3 ∪ ≥ 2.1.0, < 2.1.2 ∪ ≥ 2.2.0, < 2.2.1 ∪ ≥ 2.3.0, < 2.3.1
Auf 1.15.4 aktualisieren; Auf 2.0.3 aktualisieren; Auf 2.1.2 aktualisieren; Auf 2.2.1 aktualisieren; Auf 2.3.1 aktualisieren
Originalquellen
- https://github.com/tensorflow/tensorflow/releases/tag/v2.3.1
- https://github.com/tensorflow/tensorflow/security/advisories/GHSA-x9j7-x98r-r4w2
- https://github.com/tensorflow/tensorflow/commit/d58c96946b2880991d63d1dacacb32f0a4dfa453
- http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00065.html
- https://nvd.nist.gov/vuln/detail/CVE-2020-15210