CVE-2020-26216
CVE-2020-26216 · Cross-Site Scripting in TYPO3 Fluid
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
TYPO3 Fluid before versions 2.0.8, 2.1.7, 2.2.4, 2.3.7, 2.4.4, 2.5.11 and 2.6.10 is vulnerable to Cross-Site Scripting. Three XSS vulnerabilities have been detected in Fluid: 1. TagBasedViewHelper allowed XSS through maliciously crafted additionalAttributes arrays by creating keys with attribute-closing quotes followed by HTML. When rendering such attributes, TagBuilder would not escape the keys. 2. ViewHelpers which used the CompileWithContentArgumentAndRenderStatic trait, and which declared escapeOutput = false, would receive the content argument in unescaped format. 3. Subclasses of AbstractConditionViewHelper would receive the then and else arguments in unescaped format. Update to versions 2.0.8, 2.1.7, 2.2.4, 2.3.7, 2.4.4, 2.5.11 or 2.6.10 of this typo3fluid/fluid package that fix the problem described. More details are available in the linked advisory.
CVSS 8.0 · Alta · EPSS 1,0% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: php
Productos y versiones afectados
fluid
- Versiones
- >= 2.0.0, < 2.0.8: Afectada
- >= 2.1.0, < 2.1.7: Afectada
- >= 2.2.0, < 2.2.4: Afectada
- >= 2.3.0, < 2.3.7: Afectada
- >= 2.4.0, < 2.4.4: Afectada
- >= 2.5.0, < 2.5.11: Afectada
- >= 2.6.0, < 2.6.10: Afectada
Sin corrección publicada
typo3fluid/fluid Packagist
- Versiones
- 2.0.0
- 2.0.1
- 2.0.2
- 2.0.3
- 2.0.4
- 2.0.5
- 2.0.6
- 2.0.7
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 2.0.0, < 2.0.8
Actualiza a 2.0.8
typo3fluid/fluid Packagist
- Versiones
- 2.1.0
- 2.1.1
- 2.1.2
- 2.1.3
- 2.1.4
- 2.1.5
- 2.1.6
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 2.1.0, < 2.1.7
Actualiza a 2.1.7
typo3fluid/fluid Packagist
- Versiones
- 2.2.0
- 2.2.1
- 2.2.2
- 2.2.3
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 2.2.0, < 2.2.4
Actualiza a 2.2.4
typo3fluid/fluid Packagist
- Versiones
- 2.3.0
- 2.3.1
- 2.3.2
- 2.3.3
- 2.3.4
- 2.3.5
- 2.3.6
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 2.3.0, < 2.3.7
Actualiza a 2.3.7
typo3fluid/fluid Packagist
- Versiones
- 2.4.0
- 2.4.1
- 2.4.2
- 2.4.3
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 2.4.0, < 2.4.4
Actualiza a 2.4.4
typo3fluid/fluid Packagist
- Versiones
- 2.5.0
- 2.5.1
- 2.5.10
- 2.5.2
- 2.5.3
- 2.5.4
- 2.5.5
- 2.5.6
- 2.5.7
- 2.5.8
- 2.5.9
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 2.5.0, < 2.5.11
Actualiza a 2.5.11
typo3fluid/fluid Packagist
- Versiones
- 2.6.0
- 2.6.1
- 2.6.2
- 2.6.3
- 2.6.4
- 2.6.5
- 2.6.6
- 2.6.7
- 2.6.8
- 2.6.9
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 2.6.0, < 2.6.10
Actualiza a 2.6.10