CVE-2020-26216
CVE-2020-26216 · Cross-Site Scripting in TYPO3 Fluid
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
TYPO3 Fluid before versions 2.0.8, 2.1.7, 2.2.4, 2.3.7, 2.4.4, 2.5.11 and 2.6.10 is vulnerable to Cross-Site Scripting. Three XSS vulnerabilities have been detected in Fluid: 1. TagBasedViewHelper allowed XSS through maliciously crafted additionalAttributes arrays by creating keys with attribute-closing quotes followed by HTML. When rendering such attributes, TagBuilder would not escape the keys. 2. ViewHelpers which used the CompileWithContentArgumentAndRenderStatic trait, and which declared escapeOutput = false, would receive the content argument in unescaped format. 3. Subclasses of AbstractConditionViewHelper would receive the then and else arguments in unescaped format. Update to versions 2.0.8, 2.1.7, 2.2.4, 2.3.7, 2.4.4, 2.5.11 or 2.6.10 of this typo3fluid/fluid package that fix the problem described. More details are available in the linked advisory.
CVSS 8.0 · Hoch · EPSS 1,0% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: php
Betroffene Produkte und Versionen
fluid
- Softwareversionen
- >= 2.0.0, < 2.0.8: Betroffen
- >= 2.1.0, < 2.1.7: Betroffen
- >= 2.2.0, < 2.2.4: Betroffen
- >= 2.3.0, < 2.3.7: Betroffen
- >= 2.4.0, < 2.4.4: Betroffen
- >= 2.5.0, < 2.5.11: Betroffen
- >= 2.6.0, < 2.6.10: Betroffen
Keine Korrektur veröffentlicht
typo3fluid/fluid Packagist
- Softwareversionen
- 2.0.0
- 2.0.1
- 2.0.2
- 2.0.3
- 2.0.4
- 2.0.5
- 2.0.6
- 2.0.7
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.0.0, < 2.0.8
Auf 2.0.8 aktualisieren
typo3fluid/fluid Packagist
- Softwareversionen
- 2.1.0
- 2.1.1
- 2.1.2
- 2.1.3
- 2.1.4
- 2.1.5
- 2.1.6
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.1.0, < 2.1.7
Auf 2.1.7 aktualisieren
typo3fluid/fluid Packagist
- Softwareversionen
- 2.2.0
- 2.2.1
- 2.2.2
- 2.2.3
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.2.0, < 2.2.4
Auf 2.2.4 aktualisieren
typo3fluid/fluid Packagist
- Softwareversionen
- 2.3.0
- 2.3.1
- 2.3.2
- 2.3.3
- 2.3.4
- 2.3.5
- 2.3.6
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.3.0, < 2.3.7
Auf 2.3.7 aktualisieren
typo3fluid/fluid Packagist
- Softwareversionen
- 2.4.0
- 2.4.1
- 2.4.2
- 2.4.3
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.4.0, < 2.4.4
Auf 2.4.4 aktualisieren
typo3fluid/fluid Packagist
- Softwareversionen
- 2.5.0
- 2.5.1
- 2.5.10
- 2.5.2
- 2.5.3
- 2.5.4
- 2.5.5
- 2.5.6
- 2.5.7
- 2.5.8
- 2.5.9
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.5.0, < 2.5.11
Auf 2.5.11 aktualisieren
typo3fluid/fluid Packagist
- Softwareversionen
- 2.6.0
- 2.6.1
- 2.6.2
- 2.6.3
- 2.6.4
- 2.6.5
- 2.6.6
- 2.6.7
- 2.6.8
- 2.6.9
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.6.0, < 2.6.10
Auf 2.6.10 aktualisieren