p PatchFirst

CVE-2020-26269

CVE-2020-26269 · Heap out of bounds read in filesystem glob matching in TensorFlow

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

In TensorFlow release candidate versions 2.4.0rc*, the general implementation for matching filesystem paths to globbing pattern is vulnerable to an access out of bounds of the array holding the directories. There are multiple invariants and preconditions that are assumed by the parallel implementation of GetMatchingPaths but are not verified by the PRs introducing it (#40861 and #44310). Thus, we are completely rewriting the implementation to fully specify and validate these. This is patched in version 2.4.0. This issue only impacts master branch and the release candidates for TF version 2.4. The final release of the 2.4 release will be patched.

CVSS 9.1 · Crítica · EPSS 0,7% · Corrección disponible

Publicación
Actualización

Pila tecnológica: python

Productos y versiones afectados

  • tensorflow

    Versiones
    • .4.0rc*: Afectada

    Sin corrección publicada

  • tensorflow PyPI

    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 2.4.0rc0, < 2.4.0

    Actualiza a 2.4.0

  • tensorflow-cpu PyPI

    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 2.4.0rc0, < 2.4.0

    Actualiza a 2.4.0

  • tensorflow-gpu PyPI

    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 2.4.0rc0, < 2.4.0

    Actualiza a 2.4.0

  • tensorflow PyPI

    Versiones
    • 2.4.0rc0
    • 2.4.0rc1
    • 2.4.0rc2
    • 2.4.0rc3
    • 2.4.0rc4
    Intervalos de versiones afectados
    • GIT: < 8b5b9dc96666a3a5d27fad7179ff215e3b74b67c
    • ECOSYSTEM: ≥ 2.4.0rc0, < 2.4.0

    Actualiza a 2.4.0

  • tensorflow-cpu PyPI

    Intervalos de versiones afectados
    • GIT: < 8b5b9dc96666a3a5d27fad7179ff215e3b74b67c
    • ECOSYSTEM: ≥ 2.4.0rc0, < 2.4.0

    Actualiza a 2.4.0

  • tensorflow-gpu PyPI

    Intervalos de versiones afectados
    • GIT: < 8b5b9dc96666a3a5d27fad7179ff215e3b74b67c
    • ECOSYSTEM: ≥ 2.4.0rc0, < 2.4.0

    Actualiza a 2.4.0

Fuentes originales

Comprueba tu servidor →