CVE-2020-26269
CVE-2020-26269 · Heap out of bounds read in filesystem glob matching in TensorFlow
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
In TensorFlow release candidate versions 2.4.0rc*, the general implementation for matching filesystem paths to globbing pattern is vulnerable to an access out of bounds of the array holding the directories. There are multiple invariants and preconditions that are assumed by the parallel implementation of GetMatchingPaths but are not verified by the PRs introducing it (#40861 and #44310). Thus, we are completely rewriting the implementation to fully specify and validate these. This is patched in version 2.4.0. This issue only impacts master branch and the release candidates for TF version 2.4. The final release of the 2.4 release will be patched.
CVSS 9.1 · Kritisch · EPSS 0,7% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: python
Betroffene Produkte und Versionen
tensorflow
- Softwareversionen
- .4.0rc*: Betroffen
Keine Korrektur veröffentlicht
tensorflow PyPI
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.4.0rc0, < 2.4.0
Auf 2.4.0 aktualisieren
tensorflow-cpu PyPI
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.4.0rc0, < 2.4.0
Auf 2.4.0 aktualisieren
tensorflow-gpu PyPI
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.4.0rc0, < 2.4.0
Auf 2.4.0 aktualisieren
tensorflow PyPI
- Softwareversionen
- 2.4.0rc0
- 2.4.0rc1
- 2.4.0rc2
- 2.4.0rc3
- 2.4.0rc4
- Betroffene Versionsbereiche
- GIT: < 8b5b9dc96666a3a5d27fad7179ff215e3b74b67c
- ECOSYSTEM: ≥ 2.4.0rc0, < 2.4.0
Auf 2.4.0 aktualisieren
tensorflow-cpu PyPI
- Betroffene Versionsbereiche
- GIT: < 8b5b9dc96666a3a5d27fad7179ff215e3b74b67c
- ECOSYSTEM: ≥ 2.4.0rc0, < 2.4.0
Auf 2.4.0 aktualisieren
tensorflow-gpu PyPI
- Betroffene Versionsbereiche
- GIT: < 8b5b9dc96666a3a5d27fad7179ff215e3b74b67c
- ECOSYSTEM: ≥ 2.4.0rc0, < 2.4.0
Auf 2.4.0 aktualisieren