p PatchFirst

CVE-2020-5255

CVE-2020-5255 · Prevent cache poisoning via a Response Content-Type header

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

In Symfony before versions 4.4.7 and 5.0.7, when a `Response` does not contain a `Content-Type` header, affected versions of Symfony can fallback to the format defined in the `Accept` header of the request, leading to a possible mismatch between the response's content and `Content-Type` header. When the response is cached, this can prevent the use of the website by other users. This has been patched in versions 4.4.7 and 5.0.7.

CVSS 2.6 · Baja · EPSS 1,3% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · php

Productos y versiones afectados

  • symfony

    Versiones
    • >= 4.4.0 and < 4.4.7: Afectada
    • >= 5.0.0 and < 5.0.7: Afectada

    Sin corrección publicada

  • symfony Debian:12

    Intervalos de versiones afectados
    • ECOSYSTEM: < 4.4.8-1

    Actualiza a 4.4.8-1

  • symfony Debian:13

    Intervalos de versiones afectados
    • ECOSYSTEM: < 4.4.8-1

    Actualiza a 4.4.8-1

  • symfony Debian:14

    Intervalos de versiones afectados
    • ECOSYSTEM: < 4.4.8-1

    Actualiza a 4.4.8-1

  • symfony/http-foundation Packagist

    Versiones
    • v4.4.0
    • v4.4.1
    • v4.4.2
    • v4.4.3
    • v4.4.4
    • v4.4.5
    • v4.4.6
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 4.4.0, < 4.4.7

    Actualiza a 4.4.7

  • symfony/http-foundation Packagist

    Versiones
    • v5.0.0
    • v5.0.1
    • v5.0.2
    • v5.0.3
    • v5.0.4
    • v5.0.5
    • v5.0.6
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 5.0.0, < 5.0.7

    Actualiza a 5.0.7

  • symfony/symfony Packagist

    Versiones
    • v4.4.0
    • v4.4.1
    • v4.4.2
    • v4.4.3
    • v4.4.4
    • v4.4.5
    • v4.4.6
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 4.4.0, < 4.4.7

    Actualiza a 4.4.7

  • symfony/symfony Packagist

    Versiones
    • v5.0.0
    • v5.0.1
    • v5.0.2
    • v5.0.3
    • v5.0.4
    • v5.0.5
    • v5.0.6
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 5.0.0, < 5.0.7

    Actualiza a 5.0.7

Fuentes originales

Comprueba tu servidor →