p PatchFirst

CVE-2020-5255

CVE-2020-5255 · Prevent cache poisoning via a Response Content-Type header

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

In Symfony before versions 4.4.7 and 5.0.7, when a `Response` does not contain a `Content-Type` header, affected versions of Symfony can fallback to the format defined in the `Accept` header of the request, leading to a possible mismatch between the response's content and `Content-Type` header. When the response is cached, this can prevent the use of the website by other users. This has been patched in versions 4.4.7 and 5.0.7.

CVSS 2.6 · Niedrig · EPSS 1,3% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · php

Betroffene Produkte und Versionen

  • symfony

    Softwareversionen
    • >= 4.4.0 and < 4.4.7: Betroffen
    • >= 5.0.0 and < 5.0.7: Betroffen

    Keine Korrektur veröffentlicht

  • symfony Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 4.4.8-1

    Auf 4.4.8-1 aktualisieren

  • symfony Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 4.4.8-1

    Auf 4.4.8-1 aktualisieren

  • symfony Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 4.4.8-1

    Auf 4.4.8-1 aktualisieren

  • symfony/http-foundation Packagist

    Softwareversionen
    • v4.4.0
    • v4.4.1
    • v4.4.2
    • v4.4.3
    • v4.4.4
    • v4.4.5
    • v4.4.6
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 4.4.0, < 4.4.7

    Auf 4.4.7 aktualisieren

  • symfony/http-foundation Packagist

    Softwareversionen
    • v5.0.0
    • v5.0.1
    • v5.0.2
    • v5.0.3
    • v5.0.4
    • v5.0.5
    • v5.0.6
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 5.0.0, < 5.0.7

    Auf 5.0.7 aktualisieren

  • symfony/symfony Packagist

    Softwareversionen
    • v4.4.0
    • v4.4.1
    • v4.4.2
    • v4.4.3
    • v4.4.4
    • v4.4.5
    • v4.4.6
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 4.4.0, < 4.4.7

    Auf 4.4.7 aktualisieren

  • symfony/symfony Packagist

    Softwareversionen
    • v5.0.0
    • v5.0.1
    • v5.0.2
    • v5.0.3
    • v5.0.4
    • v5.0.5
    • v5.0.6
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 5.0.0, < 5.0.7

    Auf 5.0.7 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →