p PatchFirst

CVE-2020-5267

CVE-2020-5267 · Possible XSS vulnerability in ActionView

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

In ActionView before versions 6.0.2.2 and 5.2.4.2, there is a possible XSS vulnerability in ActionView's JavaScript literal escape helpers. Views that use the `j` or `escape_javascript` methods may be susceptible to XSS attacks. The issue is fixed in versions 6.0.2.2 and 5.2.4.2.

CVSS 4.0 · Media · EPSS 1,5% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • actionview

    Versiones
    • < 5.2.4.2: Afectada
    • >= 6.0.0, < 6.0.2.2: Afectada

    Sin corrección publicada

  • rails Debian:12

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2:5.2.4.1+dfsg-2

    Actualiza a 2:5.2.4.1+dfsg-2

  • rails Debian:13

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2:5.2.4.1+dfsg-2

    Actualiza a 2:5.2.4.1+dfsg-2

  • rails Debian:14

    Intervalos de versiones afectados
    • ECOSYSTEM: < 2:5.2.4.1+dfsg-2

    Actualiza a 2:5.2.4.1+dfsg-2

  • rails Ubuntu:Pro:16.04:LTS

    Versiones
    • 2:4.1.10-1
    • 2:4.2.5-1
    • 2:4.2.5.1-1
    • 2:4.2.5.2-2
    • 2:4.2.6-1
    • 2:4.2.6-1ubuntu0.1~esm1
    • 2:4.2.6-1ubuntu0.1~esm2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • rails Ubuntu:Pro:18.04:LTS

    Versiones
    • 2:4.2.9-2
    • 2:4.2.9-4
    • 2:4.2.10-0ubuntu4
    • 2:4.2.10-0ubuntu4+esm1
    • 2:4.2.10-0ubuntu4+esm2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • rails Ubuntu:Pro:20.04:LTS

    Versiones
    • 2:5.2.2.1+dfsg-1ubuntu1
    • 2:5.2.3+dfsg-3
    • 2:5.2.3+dfsg-3ubuntu0.1~esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →