p PatchFirst

CVE-2020-5267

CVE-2020-5267 · Possible XSS vulnerability in ActionView

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

In ActionView before versions 6.0.2.2 and 5.2.4.2, there is a possible XSS vulnerability in ActionView's JavaScript literal escape helpers. Views that use the `j` or `escape_javascript` methods may be susceptible to XSS attacks. The issue is fixed in versions 6.0.2.2 and 5.2.4.2.

CVSS 4.0 · Moyenne · EPSS 1,5% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system

Produits et versions concernés

  • actionview

    Versions du logiciel
    • < 5.2.4.2: Concernée
    • >= 6.0.0, < 6.0.2.2: Concernée

    Aucun correctif publié

  • rails Debian:12

    Plages de versions concernées
    • ECOSYSTEM: < 2:5.2.4.1+dfsg-2

    Mettez à jour vers 2:5.2.4.1+dfsg-2

  • rails Debian:13

    Plages de versions concernées
    • ECOSYSTEM: < 2:5.2.4.1+dfsg-2

    Mettez à jour vers 2:5.2.4.1+dfsg-2

  • rails Debian:14

    Plages de versions concernées
    • ECOSYSTEM: < 2:5.2.4.1+dfsg-2

    Mettez à jour vers 2:5.2.4.1+dfsg-2

  • rails Ubuntu:Pro:16.04:LTS

    Versions du logiciel
    • 2:4.1.10-1
    • 2:4.2.5-1
    • 2:4.2.5.1-1
    • 2:4.2.5.2-2
    • 2:4.2.6-1
    • 2:4.2.6-1ubuntu0.1~esm1
    • 2:4.2.6-1ubuntu0.1~esm2
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • rails Ubuntu:Pro:18.04:LTS

    Versions du logiciel
    • 2:4.2.9-2
    • 2:4.2.9-4
    • 2:4.2.10-0ubuntu4
    • 2:4.2.10-0ubuntu4+esm1
    • 2:4.2.10-0ubuntu4+esm2
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • rails Ubuntu:Pro:20.04:LTS

    Versions du logiciel
    • 2:5.2.2.1+dfsg-1ubuntu1
    • 2:5.2.3+dfsg-3
    • 2:5.2.3+dfsg-3ubuntu0.1~esm1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

Sources originales

Vérifiez votre serveur →