CVE-2020-5275
CVE-2020-5275 · Firewall configured with unanimous strategy was not actually unanimous in symfony/security-http
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
In symfony/security-http before versions 4.4.7 and 5.0.7, when a `Firewall` checks access control rule, it iterate overs each rule's attributes and stops as soon as the accessDecisionManager decides to grant access on the attribute, preventing the check of next attributes that should have been take into account in an unanimous strategy. The accessDecisionManager is now called with all attributes at once, allowing the unanimous strategy being applied on each attribute. This issue is patched in versions 4.4.7 and 5.0.7.
CVSS 7.6 · Alta · EPSS 1,1% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · php
Productos y versiones afectados
symfony
- Versiones
- >= 4.4.0, < 4.4.7: Afectada
- >= 5.0.0, < 5.0.7: Afectada
Sin corrección publicada
symfony Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 4.4.8-1
Actualiza a 4.4.8-1
symfony Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 4.4.8-1
Actualiza a 4.4.8-1
symfony Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 4.4.8-1
Actualiza a 4.4.8-1
symfony/security Packagist
- Versiones
- v4.4.0
- v4.4.1
- v4.4.2
- v4.4.3
- v4.4.4
- v4.4.5
- v4.4.6
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 4.4.0, < 4.4.7
Actualiza a 4.4.7
symfony/security Packagist
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 5.0.0, < 5.0.7
Actualiza a 5.0.7
symfony/security-http Packagist
- Versiones
- v4.4.0
- v4.4.1
- v4.4.2
- v4.4.3
- v4.4.4
- v4.4.5
- v4.4.6
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 4.4.0, < 4.4.7
Actualiza a 4.4.7
symfony/security-http Packagist
- Versiones
- v5.0.0
- v5.0.1
- v5.0.2
- v5.0.3
- v5.0.4
- v5.0.5
- v5.0.6
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 5.0.0, < 5.0.7
Actualiza a 5.0.7
symfony/symfony Packagist
- Versiones
- v4.4.0
- v4.4.1
- v4.4.2
- v4.4.3
- v4.4.4
- v4.4.5
- v4.4.6
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 4.4.0, < 4.4.7
Actualiza a 4.4.7
symfony/symfony Packagist
- Versiones
- v5.0.0
- v5.0.1
- v5.0.2
- v5.0.3
- v5.0.4
- v5.0.5
- v5.0.6
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 5.0.0, < 5.0.7
Actualiza a 5.0.7
Fuentes originales
- https://github.com/symfony/symfony/security/advisories/GHSA-g4m9-5hpf-hx72
- https://github.com/symfony/symfony/commit/c935e4a3fba6cc2ab463a6ca382858068d63cebf
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/C36JLPHUPKDFAX6D5WYFC4ALO2K7RDUQ/
- https://nvd.nist.gov/vuln/detail/CVE-2020-5275