p PatchFirst

CVE-2020-5275

CVE-2020-5275 · Firewall configured with unanimous strategy was not actually unanimous in symfony/security-http

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

In symfony/security-http before versions 4.4.7 and 5.0.7, when a `Firewall` checks access control rule, it iterate overs each rule's attributes and stops as soon as the accessDecisionManager decides to grant access on the attribute, preventing the check of next attributes that should have been take into account in an unanimous strategy. The accessDecisionManager is now called with all attributes at once, allowing the unanimous strategy being applied on each attribute. This issue is patched in versions 4.4.7 and 5.0.7.

CVSS 7.6 · Élevée · EPSS 1,1% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system · php

Produits et versions concernés

  • symfony

    Versions du logiciel
    • >= 4.4.0, < 4.4.7: Concernée
    • >= 5.0.0, < 5.0.7: Concernée

    Aucun correctif publié

  • symfony Debian:12

    Plages de versions concernées
    • ECOSYSTEM: < 4.4.8-1

    Mettez à jour vers 4.4.8-1

  • symfony Debian:13

    Plages de versions concernées
    • ECOSYSTEM: < 4.4.8-1

    Mettez à jour vers 4.4.8-1

  • symfony Debian:14

    Plages de versions concernées
    • ECOSYSTEM: < 4.4.8-1

    Mettez à jour vers 4.4.8-1

  • symfony/security Packagist

    Versions du logiciel
    • v4.4.0
    • v4.4.1
    • v4.4.2
    • v4.4.3
    • v4.4.4
    • v4.4.5
    • v4.4.6
    Plages de versions concernées
    • ECOSYSTEM: ≥ 4.4.0, < 4.4.7

    Mettez à jour vers 4.4.7

  • symfony/security Packagist

    Plages de versions concernées
    • ECOSYSTEM: ≥ 5.0.0, < 5.0.7

    Mettez à jour vers 5.0.7

  • symfony/security-http Packagist

    Versions du logiciel
    • v4.4.0
    • v4.4.1
    • v4.4.2
    • v4.4.3
    • v4.4.4
    • v4.4.5
    • v4.4.6
    Plages de versions concernées
    • ECOSYSTEM: ≥ 4.4.0, < 4.4.7

    Mettez à jour vers 4.4.7

  • symfony/security-http Packagist

    Versions du logiciel
    • v5.0.0
    • v5.0.1
    • v5.0.2
    • v5.0.3
    • v5.0.4
    • v5.0.5
    • v5.0.6
    Plages de versions concernées
    • ECOSYSTEM: ≥ 5.0.0, < 5.0.7

    Mettez à jour vers 5.0.7

  • symfony/symfony Packagist

    Versions du logiciel
    • v4.4.0
    • v4.4.1
    • v4.4.2
    • v4.4.3
    • v4.4.4
    • v4.4.5
    • v4.4.6
    Plages de versions concernées
    • ECOSYSTEM: ≥ 4.4.0, < 4.4.7

    Mettez à jour vers 4.4.7

  • symfony/symfony Packagist

    Versions du logiciel
    • v5.0.0
    • v5.0.1
    • v5.0.2
    • v5.0.3
    • v5.0.4
    • v5.0.5
    • v5.0.6
    Plages de versions concernées
    • ECOSYSTEM: ≥ 5.0.0, < 5.0.7

    Mettez à jour vers 5.0.7

Sources originales

Vérifiez votre serveur →