CVE-2020-8185
CVE-2020-8185
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
A denial of service vulnerability exists in Rails <6.0.3.2 that allowed an untrusted user to run any pending migrations on a Rails app running in production.
CVSS 6.5 · Media · EPSS 2,2%
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
https://github.com/rails/rails
- Versiones
- Fixed in 6.0.3.2: Afectada
Sin corrección publicada
rails Ubuntu:Pro:16.04:LTS
- Versiones
- 2:4.1.10-1
- 2:4.2.5-1
- 2:4.2.5.1-1
- 2:4.2.5.2-2
- 2:4.2.6-1
- 2:4.2.6-1ubuntu0.1~esm1
- 2:4.2.6-1ubuntu0.1~esm2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
rails Ubuntu:Pro:18.04:LTS
- Versiones
- 2:4.2.9-2
- 2:4.2.9-4
- 2:4.2.10-0ubuntu4
- 2:4.2.10-0ubuntu4+esm1
- 2:4.2.10-0ubuntu4+esm2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
rails Ubuntu:Pro:20.04:LTS
- Versiones
- 2:5.2.2.1+dfsg-1ubuntu1
- 2:5.2.3+dfsg-3
- 2:5.2.3+dfsg-3ubuntu0.1~esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
rails Ubuntu:Pro:22.04:LTS
- Versiones
- 2:6.0.3.7+dfsg-2
- 2:6.1.4.1+dfsg-8ubuntu2
- 2:6.1.4.1+dfsg-8ubuntu2+esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
rails Ubuntu:24.04:LTS
- Versiones
- 2:6.1.7.3+dfsg-2build1
- 2:6.1.7.3+dfsg-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
rails Ubuntu:25.10
- Versiones
- 2:6.1.7.3+dfsg-7
- 2:7.2.2.1+dfsg-7
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
rails Ubuntu:26.10
- Versiones
- 2:7.2.3+dfsg-2
- 2:7.2.3.2+dfsg-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
rails Ubuntu:26.04:LTS
- Versiones
- 2:7.2.2.1+dfsg-7
- 2:7.2.2.2+dfsg-2
- 2:7.2.3+dfsg-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada