CVE-2020-8185
CVE-2020-8185
This page contains facts from public vulnerability sources. Check the original advisory before updating.
A denial of service vulnerability exists in Rails <6.0.3.2 that allowed an untrusted user to run any pending migrations on a Rails app running in production.
CVSS 6.5 · Medium · EPSS 2.2%
- Published
- Updated
Stack: system
Affected products and versions
https://github.com/rails/rails
- Versions
- Fixed in 6.0.3.2: Affected
No fix published
rails Ubuntu:Pro:16.04:LTS
- Versions
- 2:4.1.10-1
- 2:4.2.5-1
- 2:4.2.5.1-1
- 2:4.2.5.2-2
- 2:4.2.6-1
- 2:4.2.6-1ubuntu0.1~esm1
- 2:4.2.6-1ubuntu0.1~esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
rails Ubuntu:Pro:18.04:LTS
- Versions
- 2:4.2.9-2
- 2:4.2.9-4
- 2:4.2.10-0ubuntu4
- 2:4.2.10-0ubuntu4+esm1
- 2:4.2.10-0ubuntu4+esm2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
rails Ubuntu:Pro:20.04:LTS
- Versions
- 2:5.2.2.1+dfsg-1ubuntu1
- 2:5.2.3+dfsg-3
- 2:5.2.3+dfsg-3ubuntu0.1~esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
rails Ubuntu:Pro:22.04:LTS
- Versions
- 2:6.0.3.7+dfsg-2
- 2:6.1.4.1+dfsg-8ubuntu2
- 2:6.1.4.1+dfsg-8ubuntu2+esm1
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
rails Ubuntu:24.04:LTS
- Versions
- 2:6.1.7.3+dfsg-2build1
- 2:6.1.7.3+dfsg-3
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
rails Ubuntu:25.10
- Versions
- 2:6.1.7.3+dfsg-7
- 2:7.2.2.1+dfsg-7
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
rails Ubuntu:26.10
- Versions
- 2:7.2.3+dfsg-2
- 2:7.2.3.2+dfsg-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published
rails Ubuntu:26.04:LTS
- Versions
- 2:7.2.2.1+dfsg-7
- 2:7.2.2.2+dfsg-2
- 2:7.2.3+dfsg-2
- Affected ranges
- ECOSYSTEM: (−∞, +∞)
No fix published