p PatchFirst

CVE-2021-21295

CVE-2021-21295 · Possible request smuggling in HTTP/2 due missing validation

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Esta página muestra una selección de datos de las fuentes. Consulte los avisos enlazados para ver la descripción completa y las versiones afectadas.

Netty is an open-source, asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers & clients. In Netty (io.netty:netty-codec-http2) before version 4.1.60.Final there is a vulnerability that enables request smuggling. If a Content-Length header is present in the original HTTP/2 request, the field is not validated by `Http2MultiplexHandler` as it is propagated up. This is fine as long as the request is not proxied through as HTTP/1.1. If the request comes in as an HTTP/2 stream, gets converted into the HTTP/1.1 domain objects (`HttpRequest`, `HttpContent`, etc.) via `Http2StreamFrameToHttpObjectCodec `and then sent up to the child channel's pipeline and proxied through a remote peer as HTTP/1.1 this may result in request smuggling. In a proxy case, users may assume the content-length is validated somehow, which is not the case. If the request is forwarded to a backend channel that is a HTTP/1.1 connection, the Content-Length now has meaning and needs to be checked. An attacker can smuggle requests inside the body as it gets downgraded from HTTP/2 to HTTP/1.1. For an example attack refer to the linked GitHub Advisory. Users are only affected if all of this is true: `HTTP2MultiplexCodec` or `Http2FrameCodec` is used, `Http2StreamFrameToHttpObjectCodec` is used to convert to HTTP/1.1 objects, and these HTTP/1.1 objects are forwarded to another remote peer. This has been patched in 4.1.60.Final As a workaround, the user can do the validation by themselves by implementing a custom `ChannelInboundHandler` that is put in the `ChannelPipeline` behind `Http2StreamFrameToHttpObjectCodec`.

CVSS 5.9 · Media · EPSS 18,9% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • io.netty:netty-codec-http2

    Versiones
    • < 4.1.60.Final: Afectada

    Sin corrección publicada

  • netty Debian:12

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1:4.1.48-3

    Actualiza a 1:4.1.48-3

  • netty Debian:13

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1:4.1.48-3

    Actualiza a 1:4.1.48-3

  • netty Debian:14

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1:4.1.48-3

    Actualiza a 1:4.1.48-3

  • netty Ubuntu:Pro:14.04:LTS

    Versiones
    • 1:3.2.6.Final-2
    • 1:3.2.6.Final-2+deb8u2build0.14.04.1~esm1
    • 1:3.2.6.Final-2+deb8u2ubuntu0.1~esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • netty Ubuntu:Pro:16.04:LTS

    Versiones
    • 1:3.2.6.Final-2
    • 1:4.0.32-1
    • 1:4.0.33-1
    • 1:4.0.34-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1:4.0.34-1ubuntu0.1~esm1

    Actualiza a 1:4.0.34-1ubuntu0.1~esm1

  • netty Ubuntu:Pro:18.04:LTS

    Versiones
    • 1:4.1.7-4
    • 1:4.1.7-4ubuntu0.1~esm1
    • 1:4.1.7-4ubuntu0.1
    • 1:4.1.7-4ubuntu0.1+esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1:4.1.7-4ubuntu0.1+esm2

    Actualiza a 1:4.1.7-4ubuntu0.1+esm2

  • netty Ubuntu:Pro:20.04:LTS

    Versiones
    • 1:4.1.33-1
    • 1:4.1.33-2
    • 1:4.1.33-3
    • 1:4.1.45-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1:4.1.45-1ubuntu0.1~esm1

    Actualiza a 1:4.1.45-1ubuntu0.1~esm1

  • netty Ubuntu:22.04:LTS

    Versiones
    • 1:4.1.48-4
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1:4.1.48-4+deb11u1build0.22.04.1

    Actualiza a 1:4.1.48-4+deb11u1build0.22.04.1

Fuentes originales

Comprueba tu servidor →