p PatchFirst

CVE-2021-21295

CVE-2021-21295 · Possible request smuggling in HTTP/2 due missing validation

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

Cette page présente une partie des faits des sources. Consultez les avis liés pour la description complète et les versions concernées.

Netty is an open-source, asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers & clients. In Netty (io.netty:netty-codec-http2) before version 4.1.60.Final there is a vulnerability that enables request smuggling. If a Content-Length header is present in the original HTTP/2 request, the field is not validated by `Http2MultiplexHandler` as it is propagated up. This is fine as long as the request is not proxied through as HTTP/1.1. If the request comes in as an HTTP/2 stream, gets converted into the HTTP/1.1 domain objects (`HttpRequest`, `HttpContent`, etc.) via `Http2StreamFrameToHttpObjectCodec `and then sent up to the child channel's pipeline and proxied through a remote peer as HTTP/1.1 this may result in request smuggling. In a proxy case, users may assume the content-length is validated somehow, which is not the case. If the request is forwarded to a backend channel that is a HTTP/1.1 connection, the Content-Length now has meaning and needs to be checked. An attacker can smuggle requests inside the body as it gets downgraded from HTTP/2 to HTTP/1.1. For an example attack refer to the linked GitHub Advisory. Users are only affected if all of this is true: `HTTP2MultiplexCodec` or `Http2FrameCodec` is used, `Http2StreamFrameToHttpObjectCodec` is used to convert to HTTP/1.1 objects, and these HTTP/1.1 objects are forwarded to another remote peer. This has been patched in 4.1.60.Final As a workaround, the user can do the validation by themselves by implementing a custom `ChannelInboundHandler` that is put in the `ChannelPipeline` behind `Http2StreamFrameToHttpObjectCodec`.

CVSS 5.9 · Moyenne · EPSS 18,9% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system

Produits et versions concernés

  • io.netty:netty-codec-http2

    Versions du logiciel
    • < 4.1.60.Final: Concernée

    Aucun correctif publié

  • netty Debian:12

    Plages de versions concernées
    • ECOSYSTEM: < 1:4.1.48-3

    Mettez à jour vers 1:4.1.48-3

  • netty Debian:13

    Plages de versions concernées
    • ECOSYSTEM: < 1:4.1.48-3

    Mettez à jour vers 1:4.1.48-3

  • netty Debian:14

    Plages de versions concernées
    • ECOSYSTEM: < 1:4.1.48-3

    Mettez à jour vers 1:4.1.48-3

  • netty Ubuntu:Pro:14.04:LTS

    Versions du logiciel
    • 1:3.2.6.Final-2
    • 1:3.2.6.Final-2+deb8u2build0.14.04.1~esm1
    • 1:3.2.6.Final-2+deb8u2ubuntu0.1~esm1
    Plages de versions concernées
    • ECOSYSTEM: (−∞, +∞)

    Aucun correctif publié

  • netty Ubuntu:Pro:16.04:LTS

    Versions du logiciel
    • 1:3.2.6.Final-2
    • 1:4.0.32-1
    • 1:4.0.33-1
    • 1:4.0.34-1
    Plages de versions concernées
    • ECOSYSTEM: < 1:4.0.34-1ubuntu0.1~esm1

    Mettez à jour vers 1:4.0.34-1ubuntu0.1~esm1

  • netty Ubuntu:Pro:18.04:LTS

    Versions du logiciel
    • 1:4.1.7-4
    • 1:4.1.7-4ubuntu0.1~esm1
    • 1:4.1.7-4ubuntu0.1
    • 1:4.1.7-4ubuntu0.1+esm1
    Plages de versions concernées
    • ECOSYSTEM: < 1:4.1.7-4ubuntu0.1+esm2

    Mettez à jour vers 1:4.1.7-4ubuntu0.1+esm2

  • netty Ubuntu:Pro:20.04:LTS

    Versions du logiciel
    • 1:4.1.33-1
    • 1:4.1.33-2
    • 1:4.1.33-3
    • 1:4.1.45-1
    Plages de versions concernées
    • ECOSYSTEM: < 1:4.1.45-1ubuntu0.1~esm1

    Mettez à jour vers 1:4.1.45-1ubuntu0.1~esm1

  • netty Ubuntu:22.04:LTS

    Versions du logiciel
    • 1:4.1.48-4
    Plages de versions concernées
    • ECOSYSTEM: < 1:4.1.48-4+deb11u1build0.22.04.1

    Mettez à jour vers 1:4.1.48-4+deb11u1build0.22.04.1

Sources originales

Vérifiez votre serveur →