CVE-2021-23841
CVE-2021-23841 · Null pointer deref in X509_issuer_and_serial_hash()
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
The OpenSSL public API function X509_issuer_and_serial_hash() attempts to create a unique hash value based on the issuer and serial number data contained within an X509 certificate. However it fails to correctly handle any errors that may occur while parsing the issuer field (which might occur if the issuer field is maliciously constructed). This may subsequently result in a NULL pointer deref and a crash leading to a potential denial of service attack. The function X509_issuer_and_serial_hash() is never directly called by OpenSSL itself so applications are only vulnerable if they use this function directly and they use it on certificates that may have been obtained from untrusted sources. OpenSSL versions 1.1.1i and below are affected by this issue. Users of these versions should upgrade to OpenSSL 1.1.1j. OpenSSL versions 1.0.2x and below are affected by this issue. However OpenSSL 1.0.2 is out of support and no longer receiving public updates. Premium support customers of OpenSSL 1.0.2 should upgrade to 1.0.2y. Other users should upgrade to 1.1.1j. Fixed in OpenSSL 1.1.1j (Affected 1.1.1-1.1.1i). Fixed in OpenSSL 1.0.2y (Affected 1.0.2-1.0.2x).
CVSS 5.9 · Media · EPSS 7,4% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · network
Productos y versiones afectados
openssl
- Versiones
- Fixed in OpenSSL 1.1.1j (Affected 1.1.1-1.1.1i): Afectada
- Fixed in OpenSSL 1.0.2y (Affected 1.0.2-1.0.2x): Afectada
Sin corrección publicada
openssl Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.1.1j-1
Actualiza a 1.1.1j-1
openssl Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.1.1j-1
Actualiza a 1.1.1j-1
openssl Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.1.1j-1
Actualiza a 1.1.1j-1
openssl Ubuntu:Pro:14.04:LTS
- Versiones
- 1.0.1e-3ubuntu1
- 1.0.1e-4ubuntu1
- 1.0.1e-4ubuntu2
- 1.0.1e-4ubuntu3
- 1.0.1e-4ubuntu4
- 1.0.1f-1ubuntu1
- 1.0.1f-1ubuntu2
- 1.0.1f-1ubuntu2.1
- 1.0.1f-1ubuntu2.2
- 1.0.1f-1ubuntu2.3
- 1.0.1f-1ubuntu2.4
- 1.0.1f-1ubuntu2.5
- 1.0.1f-1ubuntu2.7
- 1.0.1f-1ubuntu2.8
- 1.0.1f-1ubuntu2.11
- 1.0.1f-1ubuntu2.12
- 1.0.1f-1ubuntu2.15
- 1.0.1f-1ubuntu2.16
- 1.0.1f-1ubuntu2.17
- 1.0.1f-1ubuntu2.18
- 1.0.1f-1ubuntu2.19
- 1.0.1f-1ubuntu2.20
- 1.0.1f-1ubuntu2.21
- 1.0.1f-1ubuntu2.22
- 1.0.1f-1ubuntu2.23
- 1.0.1f-1ubuntu2.24
- 1.0.1f-1ubuntu2.25
- 1.0.1f-1ubuntu2.26
- 1.0.1f-1ubuntu2.27
- 1.0.1f-1ubuntu2.27+esm1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.0.1f-1ubuntu2.27+esm2
Actualiza a 1.0.1f-1ubuntu2.27+esm2
openssl Ubuntu:16.04:LTS
- Versiones
- 1.0.2d-0ubuntu1
- 1.0.2d-0ubuntu2
- 1.0.2e-1ubuntu1
- 1.0.2f-2ubuntu1
- 1.0.2g-1ubuntu2
- 1.0.2g-1ubuntu3
- 1.0.2g-1ubuntu4
- 1.0.2g-1ubuntu4.1
- 1.0.2g-1ubuntu4.2
- 1.0.2g-1ubuntu4.4
- 1.0.2g-1ubuntu4.5
- 1.0.2g-1ubuntu4.6
- 1.0.2g-1ubuntu4.8
- 1.0.2g-1ubuntu4.9
- 1.0.2g-1ubuntu4.10
- 1.0.2g-1ubuntu4.11
- 1.0.2g-1ubuntu4.12
- 1.0.2g-1ubuntu4.13
- 1.0.2g-1ubuntu4.14
- 1.0.2g-1ubuntu4.15
- 1.0.2g-1ubuntu4.16
- 1.0.2g-1ubuntu4.17
- 1.0.2g-1ubuntu4.18
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.0.2g-1ubuntu4.19
Actualiza a 1.0.2g-1ubuntu4.19
openssl Ubuntu:18.04:LTS
- Versiones
- 1.0.2g-1ubuntu13
- 1.0.2g-1ubuntu14
- 1.0.2n-1ubuntu1
- 1.1.0g-2ubuntu1
- 1.1.0g-2ubuntu2
- 1.1.0g-2ubuntu3
- 1.1.0g-2ubuntu4
- 1.1.0g-2ubuntu4.1
- 1.1.0g-2ubuntu4.3
- 1.1.1-1ubuntu2.1~18.04.1
- 1.1.1-1ubuntu2.1~18.04.2
- 1.1.1-1ubuntu2.1~18.04.3
- 1.1.1-1ubuntu2.1~18.04.4
- 1.1.1-1ubuntu2.1~18.04.5
- 1.1.1-1ubuntu2.1~18.04.6
- 1.1.1-1ubuntu2.1~18.04.7
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.1.1-1ubuntu2.1~18.04.8
Actualiza a 1.1.1-1ubuntu2.1~18.04.8
openssl1.0 Ubuntu:18.04:LTS
- Versiones
- 1.0.2n-1ubuntu2
- 1.0.2n-1ubuntu3
- 1.0.2n-1ubuntu4
- 1.0.2n-1ubuntu5
- 1.0.2n-1ubuntu5.1
- 1.0.2n-1ubuntu5.2
- 1.0.2n-1ubuntu5.3
- 1.0.2n-1ubuntu5.4
- 1.0.2n-1ubuntu5.5
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.0.2n-1ubuntu5.6
Actualiza a 1.0.2n-1ubuntu5.6
openssl Ubuntu:20.04:LTS
- Versiones
- 1.1.1c-1ubuntu4
- 1.1.1d-2ubuntu3
- 1.1.1d-2ubuntu6
- 1.1.1f-1ubuntu1
- 1.1.1f-1ubuntu2
- 1.1.1f-1ubuntu2.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.1.1f-1ubuntu2.2
Actualiza a 1.1.1f-1ubuntu2.2
Fuentes originales
- https://www.openssl.org/news/secadv/20210216.txt
- https://git.openssl.org/gitweb/?p=openssl.git%3Ba=commitdiff%3Bh=122a19ab48091c657f7cb1fb3af9fc07bd557bbf
- https://git.openssl.org/gitweb/?p=openssl.git%3Ba=commitdiff%3Bh=8252ee4d90f3f2004d3d0aeeed003ad49c9a7807
- https://www.debian.org/security/2021/dsa-4855
- https://security.gentoo.org/glsa/202103-03
- http://seclists.org/fulldisclosure/2021/May/70
- http://seclists.org/fulldisclosure/2021/May/68
- http://seclists.org/fulldisclosure/2021/May/67
- https://www.oracle.com/security-alerts/cpuApr2021.html
- https://www.tenable.com/security/tns-2021-09
- https://security.netapp.com/advisory/ntap-20210513-0002/
- https://security.netapp.com/advisory/ntap-20210219-0009/
- https://www.tenable.com/security/tns-2021-03
- https://support.apple.com/kb/HT212529
- https://support.apple.com/kb/HT212528
- https://support.apple.com/kb/HT212534
- https://www.oracle.com//security-alerts/cpujul2021.html
- https://kb.pulsesecure.net/articles/Pulse_Security_Advisories/SA44846
- https://www.oracle.com/security-alerts/cpuoct2021.html
- https://www.oracle.com/security-alerts/cpuapr2022.html
- https://cert-portal.siemens.com/productcert/pdf/ssa-637483.pdf
- https://security.netapp.com/advisory/ntap-20240621-0006/
- https://nvd.nist.gov/vuln/detail/CVE-2021-23841