p PatchFirst

CVE-2021-23841

CVE-2021-23841 · Null pointer deref in X509_issuer_and_serial_hash()

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

The OpenSSL public API function X509_issuer_and_serial_hash() attempts to create a unique hash value based on the issuer and serial number data contained within an X509 certificate. However it fails to correctly handle any errors that may occur while parsing the issuer field (which might occur if the issuer field is maliciously constructed). This may subsequently result in a NULL pointer deref and a crash leading to a potential denial of service attack. The function X509_issuer_and_serial_hash() is never directly called by OpenSSL itself so applications are only vulnerable if they use this function directly and they use it on certificates that may have been obtained from untrusted sources. OpenSSL versions 1.1.1i and below are affected by this issue. Users of these versions should upgrade to OpenSSL 1.1.1j. OpenSSL versions 1.0.2x and below are affected by this issue. However OpenSSL 1.0.2 is out of support and no longer receiving public updates. Premium support customers of OpenSSL 1.0.2 should upgrade to 1.0.2y. Other users should upgrade to 1.1.1j. Fixed in OpenSSL 1.1.1j (Affected 1.1.1-1.1.1i). Fixed in OpenSSL 1.0.2y (Affected 1.0.2-1.0.2x).

CVSS 5.9 · Moyenne · EPSS 7,4% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system · network

Produits et versions concernés

  • openssl

    Versions du logiciel
    • Fixed in OpenSSL 1.1.1j (Affected 1.1.1-1.1.1i): Concernée
    • Fixed in OpenSSL 1.0.2y (Affected 1.0.2-1.0.2x): Concernée

    Aucun correctif publié

  • openssl Debian:12

    Plages de versions concernées
    • ECOSYSTEM: < 1.1.1j-1

    Mettez à jour vers 1.1.1j-1

  • openssl Debian:13

    Plages de versions concernées
    • ECOSYSTEM: < 1.1.1j-1

    Mettez à jour vers 1.1.1j-1

  • openssl Debian:14

    Plages de versions concernées
    • ECOSYSTEM: < 1.1.1j-1

    Mettez à jour vers 1.1.1j-1

  • openssl Ubuntu:Pro:14.04:LTS

    Versions du logiciel
    • 1.0.1e-3ubuntu1
    • 1.0.1e-4ubuntu1
    • 1.0.1e-4ubuntu2
    • 1.0.1e-4ubuntu3
    • 1.0.1e-4ubuntu4
    • 1.0.1f-1ubuntu1
    • 1.0.1f-1ubuntu2
    • 1.0.1f-1ubuntu2.1
    • 1.0.1f-1ubuntu2.2
    • 1.0.1f-1ubuntu2.3
    • 1.0.1f-1ubuntu2.4
    • 1.0.1f-1ubuntu2.5
    • 1.0.1f-1ubuntu2.7
    • 1.0.1f-1ubuntu2.8
    • 1.0.1f-1ubuntu2.11
    • 1.0.1f-1ubuntu2.12
    • 1.0.1f-1ubuntu2.15
    • 1.0.1f-1ubuntu2.16
    • 1.0.1f-1ubuntu2.17
    • 1.0.1f-1ubuntu2.18
    • 1.0.1f-1ubuntu2.19
    • 1.0.1f-1ubuntu2.20
    • 1.0.1f-1ubuntu2.21
    • 1.0.1f-1ubuntu2.22
    • 1.0.1f-1ubuntu2.23
    • 1.0.1f-1ubuntu2.24
    • 1.0.1f-1ubuntu2.25
    • 1.0.1f-1ubuntu2.26
    • 1.0.1f-1ubuntu2.27
    • 1.0.1f-1ubuntu2.27+esm1
    Plages de versions concernées
    • ECOSYSTEM: < 1.0.1f-1ubuntu2.27+esm2

    Mettez à jour vers 1.0.1f-1ubuntu2.27+esm2

  • openssl Ubuntu:16.04:LTS

    Versions du logiciel
    • 1.0.2d-0ubuntu1
    • 1.0.2d-0ubuntu2
    • 1.0.2e-1ubuntu1
    • 1.0.2f-2ubuntu1
    • 1.0.2g-1ubuntu2
    • 1.0.2g-1ubuntu3
    • 1.0.2g-1ubuntu4
    • 1.0.2g-1ubuntu4.1
    • 1.0.2g-1ubuntu4.2
    • 1.0.2g-1ubuntu4.4
    • 1.0.2g-1ubuntu4.5
    • 1.0.2g-1ubuntu4.6
    • 1.0.2g-1ubuntu4.8
    • 1.0.2g-1ubuntu4.9
    • 1.0.2g-1ubuntu4.10
    • 1.0.2g-1ubuntu4.11
    • 1.0.2g-1ubuntu4.12
    • 1.0.2g-1ubuntu4.13
    • 1.0.2g-1ubuntu4.14
    • 1.0.2g-1ubuntu4.15
    • 1.0.2g-1ubuntu4.16
    • 1.0.2g-1ubuntu4.17
    • 1.0.2g-1ubuntu4.18
    Plages de versions concernées
    • ECOSYSTEM: < 1.0.2g-1ubuntu4.19

    Mettez à jour vers 1.0.2g-1ubuntu4.19

  • openssl Ubuntu:18.04:LTS

    Versions du logiciel
    • 1.0.2g-1ubuntu13
    • 1.0.2g-1ubuntu14
    • 1.0.2n-1ubuntu1
    • 1.1.0g-2ubuntu1
    • 1.1.0g-2ubuntu2
    • 1.1.0g-2ubuntu3
    • 1.1.0g-2ubuntu4
    • 1.1.0g-2ubuntu4.1
    • 1.1.0g-2ubuntu4.3
    • 1.1.1-1ubuntu2.1~18.04.1
    • 1.1.1-1ubuntu2.1~18.04.2
    • 1.1.1-1ubuntu2.1~18.04.3
    • 1.1.1-1ubuntu2.1~18.04.4
    • 1.1.1-1ubuntu2.1~18.04.5
    • 1.1.1-1ubuntu2.1~18.04.6
    • 1.1.1-1ubuntu2.1~18.04.7
    Plages de versions concernées
    • ECOSYSTEM: < 1.1.1-1ubuntu2.1~18.04.8

    Mettez à jour vers 1.1.1-1ubuntu2.1~18.04.8

  • openssl1.0 Ubuntu:18.04:LTS

    Versions du logiciel
    • 1.0.2n-1ubuntu2
    • 1.0.2n-1ubuntu3
    • 1.0.2n-1ubuntu4
    • 1.0.2n-1ubuntu5
    • 1.0.2n-1ubuntu5.1
    • 1.0.2n-1ubuntu5.2
    • 1.0.2n-1ubuntu5.3
    • 1.0.2n-1ubuntu5.4
    • 1.0.2n-1ubuntu5.5
    Plages de versions concernées
    • ECOSYSTEM: < 1.0.2n-1ubuntu5.6

    Mettez à jour vers 1.0.2n-1ubuntu5.6

  • openssl Ubuntu:20.04:LTS

    Versions du logiciel
    • 1.1.1c-1ubuntu4
    • 1.1.1d-2ubuntu3
    • 1.1.1d-2ubuntu6
    • 1.1.1f-1ubuntu1
    • 1.1.1f-1ubuntu2
    • 1.1.1f-1ubuntu2.1
    Plages de versions concernées
    • ECOSYSTEM: < 1.1.1f-1ubuntu2.2

    Mettez à jour vers 1.1.1f-1ubuntu2.2

Sources originales

Vérifiez votre serveur →