CVE-2021-29476
CVE-2021-29476 · Insecure Deserialization of untrusted data in rmccue/requests
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Requests is a HTTP library written in PHP. Requests mishandles deserialization in FilteredIterator. The issue has been patched and users of `Requests` 1.6.0, 1.6.1 and 1.7.0 should update to version 1.8.0.
CVSS 9.8 · Crítica · EPSS 2,1% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · php
Productos y versiones afectados
requests
- Versiones
- >= 1.6.0, < 1.8.0: Afectada
Sin corrección publicada
wordpress Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 5.5.3+dfsg1-1
Actualiza a 5.5.3+dfsg1-1
wordpress Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 5.5.3+dfsg1-1
Actualiza a 5.5.3+dfsg1-1
wordpress Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 5.5.3+dfsg1-1
Actualiza a 5.5.3+dfsg1-1
rmccue/requests Packagist
- Versiones
- v1.6.0
- v1.6.1
- v1.7.0
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 1.6.0, < 1.8.0
Actualiza a 1.8.0
wordpress Ubuntu:16.04:LTS
- Versiones
- 4.3+dfsg-1
- 4.3.1+dfsg-1
- 4.4+dfsg-1
- 4.4.1+dfsg-1
- 4.4.2+dfsg-1
- 4.4.2+dfsg-1ubuntu1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
wordpress Ubuntu:18.04:LTS
- Versiones
- 4.8.2+dfsg-2
- 4.8.3+dfsg-1
- 4.9.1+dfsg-1
- 4.9.2+dfsg-1
- 4.9.4+dfsg-1
- 4.9.5+dfsg1-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
wordpress Ubuntu:20.04:LTS
- Versiones
- 5.2.2+dfsg1-1
- 5.2.4+dfsg1-1
- 5.3.2+dfsg1-1
- 5.3.2+dfsg1-1ubuntu1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada