CVE-2021-29476
CVE-2021-29476 · Insecure Deserialization of untrusted data in rmccue/requests
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Requests is a HTTP library written in PHP. Requests mishandles deserialization in FilteredIterator. The issue has been patched and users of `Requests` 1.6.0, 1.6.1 and 1.7.0 should update to version 1.8.0.
CVSS 9.8 · Critique · EPSS 2,1% · Correctif disponible
- Publication
- Mise à jour
Produits et versions concernés
requests
- Versions du logiciel
- >= 1.6.0, < 1.8.0: Concernée
Aucun correctif publié
wordpress Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 5.5.3+dfsg1-1
Mettez à jour vers 5.5.3+dfsg1-1
wordpress Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 5.5.3+dfsg1-1
Mettez à jour vers 5.5.3+dfsg1-1
wordpress Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 5.5.3+dfsg1-1
Mettez à jour vers 5.5.3+dfsg1-1
rmccue/requests Packagist
- Versions du logiciel
- v1.6.0
- v1.6.1
- v1.7.0
- Plages de versions concernées
- ECOSYSTEM: ≥ 1.6.0, < 1.8.0
Mettez à jour vers 1.8.0
wordpress Ubuntu:16.04:LTS
- Versions du logiciel
- 4.3+dfsg-1
- 4.3.1+dfsg-1
- 4.4+dfsg-1
- 4.4.1+dfsg-1
- 4.4.2+dfsg-1
- 4.4.2+dfsg-1ubuntu1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
wordpress Ubuntu:18.04:LTS
- Versions du logiciel
- 4.8.2+dfsg-2
- 4.8.3+dfsg-1
- 4.9.1+dfsg-1
- 4.9.2+dfsg-1
- 4.9.4+dfsg-1
- 4.9.5+dfsg1-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
wordpress Ubuntu:20.04:LTS
- Versions du logiciel
- 5.2.2+dfsg1-1
- 5.2.4+dfsg1-1
- 5.3.2+dfsg1-1
- 5.3.2+dfsg1-1ubuntu1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié