CVE-2021-32714
CVE-2021-32714 · Integer Overflow in Chunked Transfer-Encoding
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
hyper is an HTTP library for Rust. In versions prior to 0.14.10, hyper's HTTP server and client code had a flaw that could trigger an integer overflow when decoding chunk sizes that are too big. This allows possible data loss, or if combined with an upstream HTTP proxy that allows chunk sizes larger than hyper does, can result in "request smuggling" or "desync attacks." The vulnerability is patched in version 0.14.10. Two possible workarounds exist. One may reject requests manually that contain a `Transfer-Encoding` header or ensure any upstream proxy rejects `Transfer-Encoding` chunk sizes greater than what fits in 64-bit unsigned integers.
CVSS 5.9 · Media · EPSS 1,2% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
hyper
- Versiones
- < 0.14.10: Afectada
Sin corrección publicada
rust-hyper Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.14.19-1
Actualiza a 0.14.19-1
rust-hyper Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.14.19-1
Actualiza a 0.14.19-1
rust-hyper Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.14.19-1
Actualiza a 0.14.19-1
rust-hyper Ubuntu:20.04:LTS
- Versiones
- 0.12.35-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada