CVE-2021-32714
CVE-2021-32714 · Integer Overflow in Chunked Transfer-Encoding
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
hyper is an HTTP library for Rust. In versions prior to 0.14.10, hyper's HTTP server and client code had a flaw that could trigger an integer overflow when decoding chunk sizes that are too big. This allows possible data loss, or if combined with an upstream HTTP proxy that allows chunk sizes larger than hyper does, can result in "request smuggling" or "desync attacks." The vulnerability is patched in version 0.14.10. Two possible workarounds exist. One may reject requests manually that contain a `Transfer-Encoding` header or ensure any upstream proxy rejects `Transfer-Encoding` chunk sizes greater than what fits in 64-bit unsigned integers.
CVSS 5.9 · Moyenne · EPSS 1,2% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
hyper
- Versions du logiciel
- < 0.14.10: Concernée
Aucun correctif publié
rust-hyper Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 0.14.19-1
Mettez à jour vers 0.14.19-1
rust-hyper Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 0.14.19-1
Mettez à jour vers 0.14.19-1
rust-hyper Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 0.14.19-1
Mettez à jour vers 0.14.19-1
rust-hyper Ubuntu:20.04:LTS
- Versions du logiciel
- 0.12.35-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié