p PatchFirst

CVE-2021-32808

CVE-2021-32808 · Cross-site scripting in ckeditor via abuse of undo functionality

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

ckeditor is an open source WYSIWYG HTML editor with rich content support. A vulnerability has been discovered in the clipboard Widget plugin if used alongside the undo feature. The vulnerability allows a user to abuse undo functionality using malformed widget HTML, which could result in executing JavaScript code. It affects all users using the CKEditor 4 plugins listed above at version >= 4.13.0. The problem has been recognized and patched. The fix will be available in version 4.16.2.

CVSS 7.6 · Alta · EPSS 1,2% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · node

Productos y versiones afectados

  • ckeditor4

    Versiones
    • >= 4.13.0, < 4.16.2: Afectada

    Sin corrección publicada

  • ckeditor Debian:12

    Intervalos de versiones afectados
    • ECOSYSTEM: < 4.16.2+dfsg-1

    Actualiza a 4.16.2+dfsg-1

  • ckeditor4 npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 4.13.0, < 4.16.2

    Actualiza a 4.16.2

Fuentes originales

Comprueba tu servidor →