p PatchFirst

CVE-2021-32808

CVE-2021-32808 · Cross-site scripting in ckeditor via abuse of undo functionality

Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.

ckeditor is an open source WYSIWYG HTML editor with rich content support. A vulnerability has been discovered in the clipboard Widget plugin if used alongside the undo feature. The vulnerability allows a user to abuse undo functionality using malformed widget HTML, which could result in executing JavaScript code. It affects all users using the CKEditor 4 plugins listed above at version >= 4.13.0. The problem has been recognized and patched. The fix will be available in version 4.16.2.

CVSS 7.6 · Élevée · EPSS 1,2% · Correctif disponible

Publication
Mise à jour

Pile logicielle: system · node

Produits et versions concernés

  • ckeditor4

    Versions du logiciel
    • >= 4.13.0, < 4.16.2: Concernée

    Aucun correctif publié

  • ckeditor Debian:12

    Plages de versions concernées
    • ECOSYSTEM: < 4.16.2+dfsg-1

    Mettez à jour vers 4.16.2+dfsg-1

  • ckeditor4 npm

    Plages de versions concernées
    • SEMVER: ≥ 4.13.0, < 4.16.2

    Mettez à jour vers 4.16.2

Sources originales

Vérifiez votre serveur →