p PatchFirst

CVE-2021-37620

CVE-2021-37620 · Out-of-bounds read in XmpTextValue::read()

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. An out-of-bounds read was found in Exiv2 versions v0.27.4 and earlier. The out-of-bounds read is triggered when Exiv2 is used to read the metadata of a crafted image file. An attacker could potentially exploit the vulnerability to cause a denial of service, if they can trick the victim into running Exiv2 on a crafted image file. The bug is fixed in version v0.27.5.

CVSS 4.7 · Media · EPSS 1,1% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • exiv2

    Versiones
    • <= 0.27.4: Afectada

    Sin corrección publicada

  • exiv2 Debian:12

    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.27.5-1

    Actualiza a 0.27.5-1

  • exiv2 Debian:13

    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.27.5-1

    Actualiza a 0.27.5-1

  • exiv2 Debian:14

    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.27.5-1

    Actualiza a 0.27.5-1

  • exiv2 Ubuntu:Pro:16.04:LTS

    Versiones
    • 0.25-1ubuntu1
    • 0.25-2.1
    • 0.25-2.1ubuntu16.04.1
    • 0.25-2.1ubuntu16.04.2
    • 0.25-2.1ubuntu16.04.3
    • 0.25-2.1ubuntu16.04.4
    • 0.25-2.1ubuntu16.04.5
    • 0.25-2.1ubuntu16.04.6
    • 0.25-2.1ubuntu16.04.7+esm1
    • 0.25-2.1ubuntu16.04.7+esm2
    • 0.25-2.1ubuntu16.04.7+esm3
    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.25-2.1ubuntu16.04.7+esm4

    Actualiza a 0.25-2.1ubuntu16.04.7+esm4

  • exiv2 Ubuntu:18.04:LTS

    Versiones
    • 0.25-3.1
    • 0.25-3.1ubuntu0.18.04.1
    • 0.25-3.1ubuntu0.18.04.2
    • 0.25-3.1ubuntu0.18.04.3
    • 0.25-3.1ubuntu0.18.04.4
    • 0.25-3.1ubuntu0.18.04.5
    • 0.25-3.1ubuntu0.18.04.7
    • 0.25-3.1ubuntu0.18.04.9
    • 0.25-3.1ubuntu0.18.04.10
    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.25-3.1ubuntu0.18.04.11

    Actualiza a 0.25-3.1ubuntu0.18.04.11

  • exiv2 Ubuntu:20.04:LTS

    Versiones
    • 0.25-4ubuntu2
    • 0.25-4ubuntu3
    • 0.27.2-8ubuntu2
    • 0.27.2-8ubuntu2.2
    • 0.27.2-8ubuntu2.4
    • 0.27.2-8ubuntu2.5
    • 0.27.2-8ubuntu2.6
    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.27.2-8ubuntu2.7

    Actualiza a 0.27.2-8ubuntu2.7

  • exiv2 Ubuntu:22.04:LTS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.27.3-3ubuntu4

    Actualiza a 0.27.3-3ubuntu4

Fuentes originales

Comprueba tu servidor →