CVE-2021-37620
CVE-2021-37620 · Out-of-bounds read in XmpTextValue::read()
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Exiv2 is a command-line utility and C++ library for reading, writing, deleting, and modifying the metadata of image files. An out-of-bounds read was found in Exiv2 versions v0.27.4 and earlier. The out-of-bounds read is triggered when Exiv2 is used to read the metadata of a crafted image file. An attacker could potentially exploit the vulnerability to cause a denial of service, if they can trick the victim into running Exiv2 on a crafted image file. The bug is fixed in version v0.27.5.
CVSS 4.7 · Moyenne · EPSS 1,1% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
exiv2
- Versions du logiciel
- <= 0.27.4: Concernée
Aucun correctif publié
exiv2 Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 0.27.5-1
Mettez à jour vers 0.27.5-1
exiv2 Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 0.27.5-1
Mettez à jour vers 0.27.5-1
exiv2 Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 0.27.5-1
Mettez à jour vers 0.27.5-1
exiv2 Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 0.25-1ubuntu1
- 0.25-2.1
- 0.25-2.1ubuntu16.04.1
- 0.25-2.1ubuntu16.04.2
- 0.25-2.1ubuntu16.04.3
- 0.25-2.1ubuntu16.04.4
- 0.25-2.1ubuntu16.04.5
- 0.25-2.1ubuntu16.04.6
- 0.25-2.1ubuntu16.04.7+esm1
- 0.25-2.1ubuntu16.04.7+esm2
- 0.25-2.1ubuntu16.04.7+esm3
- Plages de versions concernées
- ECOSYSTEM: < 0.25-2.1ubuntu16.04.7+esm4
Mettez à jour vers 0.25-2.1ubuntu16.04.7+esm4
exiv2 Ubuntu:18.04:LTS
- Versions du logiciel
- 0.25-3.1
- 0.25-3.1ubuntu0.18.04.1
- 0.25-3.1ubuntu0.18.04.2
- 0.25-3.1ubuntu0.18.04.3
- 0.25-3.1ubuntu0.18.04.4
- 0.25-3.1ubuntu0.18.04.5
- 0.25-3.1ubuntu0.18.04.7
- 0.25-3.1ubuntu0.18.04.9
- 0.25-3.1ubuntu0.18.04.10
- Plages de versions concernées
- ECOSYSTEM: < 0.25-3.1ubuntu0.18.04.11
Mettez à jour vers 0.25-3.1ubuntu0.18.04.11
exiv2 Ubuntu:20.04:LTS
- Versions du logiciel
- 0.25-4ubuntu2
- 0.25-4ubuntu3
- 0.27.2-8ubuntu2
- 0.27.2-8ubuntu2.2
- 0.27.2-8ubuntu2.4
- 0.27.2-8ubuntu2.5
- 0.27.2-8ubuntu2.6
- Plages de versions concernées
- ECOSYSTEM: < 0.27.2-8ubuntu2.7
Mettez à jour vers 0.27.2-8ubuntu2.7
exiv2 Ubuntu:22.04:LTS
- Plages de versions concernées
- ECOSYSTEM: < 0.27.3-3ubuntu4
Mettez à jour vers 0.27.3-3ubuntu4
Sources originales
- https://github.com/Exiv2/exiv2/security/advisories/GHSA-v5g7-46xf-h728
- https://github.com/Exiv2/exiv2/pull/1769
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/FMDT4PJB7P43WSOM3TRQIY3J33BAFVVE/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/UYGDELIFFJWKUU7SO3QATCIXCZJERGAC/
- https://lists.debian.org/debian-lts-announce/2023/01/msg00004.html
- https://security.gentoo.org/glsa/202312-06
- https://nvd.nist.gov/vuln/detail/CVE-2021-37620