p PatchFirst

CVE-2021-39178

CVE-2021-39178 · XSS in Image Optimization API for Next.js versions between 10.0.0 and 11.1.0

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Next.js is a React framework. Versions of Next.js between 10.0.0 and 11.0.0 contain a cross-site scripting vulnerability. In order for an instance to be affected by the vulnerability, the `next.config.js` file must have `images.domains` array assigned and the image host assigned in `images.domains` must allow user-provided SVG. If the `next.config.js` file has `images.loader` assigned to something other than default or the instance is deployed on Vercel, the instance is not affected by the vulnerability. The vulnerability is patched in Next.js version 11.1.1.

CVSS 7.5 · Alta · EPSS 1,1% · Corrección disponible

Publicación
Actualización

Pila tecnológica: node

Productos y versiones afectados

  • next.js

    Versiones
    • >= 10.0.0, < 11.1.1: Afectada

    Sin corrección publicada

  • next npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 10.0.0, < 11.1.1

    Actualiza a 11.1.1

Fuentes originales

Comprueba tu servidor →