p PatchFirst

CVE-2021-39178

CVE-2021-39178 · XSS in Image Optimization API for Next.js versions between 10.0.0 and 11.1.0

This page contains facts from public vulnerability sources. Check the original advisory before updating.

Next.js is a React framework. Versions of Next.js between 10.0.0 and 11.0.0 contain a cross-site scripting vulnerability. In order for an instance to be affected by the vulnerability, the `next.config.js` file must have `images.domains` array assigned and the image host assigned in `images.domains` must allow user-provided SVG. If the `next.config.js` file has `images.loader` assigned to something other than default or the instance is deployed on Vercel, the instance is not affected by the vulnerability. The vulnerability is patched in Next.js version 11.1.1.

CVSS 7.5 · High · EPSS 1.1% · Fix available

Published
Updated

Stack: node

Affected products and versions

  • next.js

    Versions
    • >= 10.0.0, < 11.1.1: Affected

    No fix published

  • next npm

    Affected ranges
    • SEMVER: ≥ 10.0.0, < 11.1.1

    Update to 11.1.1

Original sources

Check your server →