p PatchFirst

CVE-2021-39192

CVE-2021-39192 · Privilege escalation: all users can access Admin-level API keys

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Ghost is a Node.js content management system. An error in the implementation of the limits service between versions 4.0.0 and 4.9.4 allows all authenticated users (including contributors) to view admin-level API keys via the integrations API endpoint, leading to a privilege escalation vulnerability. This issue is patched in Ghost version 4.10.0. As a workaround, disable all non-Administrator accounts to prevent API access. It is highly recommended to regenerate all API keys after patching or applying the workaround.

CVSS 6.5 · Media · EPSS 1,0% · Corrección disponible

Publicación
Actualización

Pila tecnológica: node

Productos y versiones afectados

  • ghost

    Versiones
    • >= 4.0.0, < 4.10.0: Afectada

    Sin corrección publicada

  • ghost npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 4.0.0, < 4.10.0

    Actualiza a 4.10.0

Fuentes originales

Comprueba tu servidor →