p PatchFirst

CVE-2021-39192

CVE-2021-39192 · Privilege escalation: all users can access Admin-level API keys

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Ghost is a Node.js content management system. An error in the implementation of the limits service between versions 4.0.0 and 4.9.4 allows all authenticated users (including contributors) to view admin-level API keys via the integrations API endpoint, leading to a privilege escalation vulnerability. This issue is patched in Ghost version 4.10.0. As a workaround, disable all non-Administrator accounts to prevent API access. It is highly recommended to regenerate all API keys after patching or applying the workaround.

CVSS 6.5 · Mittel · EPSS 1,0% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • ghost

    Softwareversionen
    • >= 4.0.0, < 4.10.0: Betroffen

    Keine Korrektur veröffentlicht

  • ghost npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 4.0.0, < 4.10.0

    Auf 4.10.0 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →