p PatchFirst

CVE-2021-41103

CVE-2021-41103 · Insufficiently restricted permissions on plugin directories

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

containerd is an open source container runtime with an emphasis on simplicity, robustness and portability. A bug was found in containerd where container root directories and some plugins had insufficiently restricted permissions, allowing otherwise unprivileged Linux users to traverse directory contents and execute programs. When containers included executable programs with extended permission bits (such as setuid), unprivileged Linux users could discover and execute those programs. When the UID of an unprivileged Linux user on the host collided with the file owner or group inside a container, the unprivileged Linux user on the host could discover, read, and modify those files. This vulnerability has been fixed in containerd 1.4.11 and containerd 1.5.7. Users should update to these version when they are released and may restart containers or update directory permissions to mitigate the vulnerability. Users unable to update should limit access to the host to trusted users. Update directory permission on container bundles directories.

CVSS 5.9 · Media · EPSS 0,5% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · containers

Productos y versiones afectados

  • containerd

    Versiones
    • < 1.4.11: Afectada
    • >= 1.5.0, < 1.5.7: Afectada

    Sin corrección publicada

  • containerd Debian:12

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.5.7~ds1-1

    Actualiza a 1.5.7~ds1-1

  • containerd Debian:13

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.5.7~ds1-1

    Actualiza a 1.5.7~ds1-1

  • containerd Debian:14

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.5.7~ds1-1

    Actualiza a 1.5.7~ds1-1

  • containerd Ubuntu:Pro:16.04:LTS

    Versiones
    • 0.2.1-0ubuntu4~16.04
    • 0.2.3-0ubuntu1~16.04
    • 0.2.5-0ubuntu1~16.04.1
    • 1.2.6-0ubuntu1~16.04.2
    • 1.2.6-0ubuntu1~16.04.3
    • 1.2.6-0ubuntu1~16.04.4
    • 1.2.6-0ubuntu1~16.04.5
    • 1.2.6-0ubuntu1~16.04.6
    • 1.2.6-0ubuntu1~16.04.6+esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.2.6-0ubuntu1~16.04.6+esm2

    Actualiza a 1.2.6-0ubuntu1~16.04.6+esm2

  • containerd Ubuntu:18.04:LTS

    Versiones
    • 0.2.5-0ubuntu2
    • 1.2.6-0ubuntu1~18.04.1
    • 1.2.6-0ubuntu1~18.04.2
    • 1.3.3-0ubuntu1~18.04.1
    • 1.3.3-0ubuntu1~18.04.2
    • 1.3.3-0ubuntu1~18.04.3
    • 1.3.3-0ubuntu1~18.04.4
    • 1.4.4-0ubuntu1~18.04.2
    • 1.5.2-0ubuntu1~18.04.1
    • 1.5.2-0ubuntu1~18.04.2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.5.2-0ubuntu1~18.04.3

    Actualiza a 1.5.2-0ubuntu1~18.04.3

  • containerd Ubuntu:20.04:LTS

    Versiones
    • 1.2.10-0ubuntu1
    • 1.3.2-0ubuntu1
    • 1.3.3-0ubuntu1
    • 1.3.3-0ubuntu2
    • 1.3.3-0ubuntu2.1
    • 1.3.3-0ubuntu2.2
    • 1.3.3-0ubuntu2.3
    • 1.4.4-0ubuntu1~20.04.2
    • 1.5.2-0ubuntu1~20.04.1
    • 1.5.2-0ubuntu1~20.04.2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.5.2-0ubuntu1~20.04.3

    Actualiza a 1.5.2-0ubuntu1~20.04.3

  • containerd Ubuntu:22.04:LTS

    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.5.5-0ubuntu3

    Actualiza a 1.5.5-0ubuntu3

Fuentes originales

Comprueba tu servidor →