CVE-2021-41103
CVE-2021-41103 · Insufficiently restricted permissions on plugin directories
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
containerd is an open source container runtime with an emphasis on simplicity, robustness and portability. A bug was found in containerd where container root directories and some plugins had insufficiently restricted permissions, allowing otherwise unprivileged Linux users to traverse directory contents and execute programs. When containers included executable programs with extended permission bits (such as setuid), unprivileged Linux users could discover and execute those programs. When the UID of an unprivileged Linux user on the host collided with the file owner or group inside a container, the unprivileged Linux user on the host could discover, read, and modify those files. This vulnerability has been fixed in containerd 1.4.11 and containerd 1.5.7. Users should update to these version when they are released and may restart containers or update directory permissions to mitigate the vulnerability. Users unable to update should limit access to the host to trusted users. Update directory permission on container bundles directories.
CVSS 5.9 · Moyenne · EPSS 0,5% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · containers
Produits et versions concernés
containerd
- Versions du logiciel
- < 1.4.11: Concernée
- >= 1.5.0, < 1.5.7: Concernée
Aucun correctif publié
containerd Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 1.5.7~ds1-1
Mettez à jour vers 1.5.7~ds1-1
containerd Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 1.5.7~ds1-1
Mettez à jour vers 1.5.7~ds1-1
containerd Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 1.5.7~ds1-1
Mettez à jour vers 1.5.7~ds1-1
containerd Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 0.2.1-0ubuntu4~16.04
- 0.2.3-0ubuntu1~16.04
- 0.2.5-0ubuntu1~16.04.1
- 1.2.6-0ubuntu1~16.04.2
- 1.2.6-0ubuntu1~16.04.3
- 1.2.6-0ubuntu1~16.04.4
- 1.2.6-0ubuntu1~16.04.5
- 1.2.6-0ubuntu1~16.04.6
- 1.2.6-0ubuntu1~16.04.6+esm1
- Plages de versions concernées
- ECOSYSTEM: < 1.2.6-0ubuntu1~16.04.6+esm2
Mettez à jour vers 1.2.6-0ubuntu1~16.04.6+esm2
containerd Ubuntu:18.04:LTS
- Versions du logiciel
- 0.2.5-0ubuntu2
- 1.2.6-0ubuntu1~18.04.1
- 1.2.6-0ubuntu1~18.04.2
- 1.3.3-0ubuntu1~18.04.1
- 1.3.3-0ubuntu1~18.04.2
- 1.3.3-0ubuntu1~18.04.3
- 1.3.3-0ubuntu1~18.04.4
- 1.4.4-0ubuntu1~18.04.2
- 1.5.2-0ubuntu1~18.04.1
- 1.5.2-0ubuntu1~18.04.2
- Plages de versions concernées
- ECOSYSTEM: < 1.5.2-0ubuntu1~18.04.3
Mettez à jour vers 1.5.2-0ubuntu1~18.04.3
containerd Ubuntu:20.04:LTS
- Versions du logiciel
- 1.2.10-0ubuntu1
- 1.3.2-0ubuntu1
- 1.3.3-0ubuntu1
- 1.3.3-0ubuntu2
- 1.3.3-0ubuntu2.1
- 1.3.3-0ubuntu2.2
- 1.3.3-0ubuntu2.3
- 1.4.4-0ubuntu1~20.04.2
- 1.5.2-0ubuntu1~20.04.1
- 1.5.2-0ubuntu1~20.04.2
- Plages de versions concernées
- ECOSYSTEM: < 1.5.2-0ubuntu1~20.04.3
Mettez à jour vers 1.5.2-0ubuntu1~20.04.3
containerd Ubuntu:22.04:LTS
- Plages de versions concernées
- ECOSYSTEM: < 1.5.5-0ubuntu3
Mettez à jour vers 1.5.5-0ubuntu3
Sources originales
- https://github.com/containerd/containerd/security/advisories/GHSA-c2h3-6mxw-7mvq
- https://github.com/containerd/containerd/commit/5b46e404f6b9f661a205e28d59c982d3634148f8
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/ZNFADTCHHYWVM6W4NJ6CB4FNFM2VMBIB/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/B5Q6G6I4W5COQE25QMC7FJY3I3PAYFBB/
- https://www.debian.org/security/2021/dsa-5002
- https://cert-portal.siemens.com/productcert/pdf/ssa-222547.pdf
- https://security.gentoo.org/glsa/202401-31
- https://nvd.nist.gov/vuln/detail/CVE-2021-41103