p PatchFirst

CVE-2021-41817

CVE-2021-41817

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Date.parse in the date gem through 3.2.0 for Ruby allows ReDoS (regular expression Denial of Service) via a long string. The fixed versions are 3.2.1, 3.1.2, 3.0.2, and 2.0.1.

CVSS 7.5 · Alta · EPSS 3,5% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • n/a

    Versiones
    • n/a: Afectada

    Sin corrección publicada

  • ruby2.7 Debian:11

    Versiones
    • 2.7.4-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.7.4-1+deb11u1

    Actualiza a 2.7.4-1+deb11u1

  • ruby2.3 Ubuntu:Pro:16.04:LTS

    Versiones
    • 2.3.0-1
    • 2.3.0-2
    • 2.3.0-4ubuntu2
    • 2.3.0-4ubuntu3
    • 2.3.0-5ubuntu1
    • 2.3.1-2~16.04
    • 2.3.1-2~16.04.2
    • 2.3.1-2~16.04.4
    • 2.3.1-2~16.04.5
    • 2.3.1-2~16.04.6
    • 2.3.1-2~16.04.7
    • 2.3.1-2~16.04.9
    • 2.3.1-2~16.04.10
    • 2.3.1-2~16.04.11
    • 2.3.1-2~16.04.12
    • 2.3.1-2~ubuntu16.04.13
    • 2.3.1-2~ubuntu16.04.14
    • 2.3.1-2~ubuntu16.04.15
    • 2.3.1-2~ubuntu16.04.16
    • 2.3.1-2~ubuntu16.04.16+esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.3.1-2~ubuntu16.04.16+esm2

    Actualiza a 2.3.1-2~ubuntu16.04.16+esm2

  • ruby2.5 Ubuntu:18.04:LTS

    Versiones
    • 2.5.0~preview1-1ubuntu2
    • 2.5.0-4ubuntu1
    • 2.5.0-4ubuntu4
    • 2.5.0-5ubuntu1
    • 2.5.0-6ubuntu1
    • 2.5.1-1ubuntu1
    • 2.5.1-1ubuntu1.1
    • 2.5.1-1ubuntu1.2
    • 2.5.1-1ubuntu1.4
    • 2.5.1-1ubuntu1.5
    • 2.5.1-1ubuntu1.6
    • 2.5.1-1ubuntu1.7
    • 2.5.1-1ubuntu1.8
    • 2.5.1-1ubuntu1.9
    • 2.5.1-1ubuntu1.10
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.5.1-1ubuntu1.11

    Actualiza a 2.5.1-1ubuntu1.11

  • ruby2.7 Ubuntu:20.04:LTS

    Versiones
    • 2.7.0-1
    • 2.7.0-2
    • 2.7.0-3
    • 2.7.0-4
    • 2.7.0-4ubuntu1
    • 2.7.0-5ubuntu1
    • 2.7.0-5ubuntu1.1
    • 2.7.0-5ubuntu1.2
    • 2.7.0-5ubuntu1.3
    • 2.7.0-5ubuntu1.4
    • 2.7.0-5ubuntu1.5
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.7.0-5ubuntu1.6

    Actualiza a 2.7.0-5ubuntu1.6

  • ruby3.0 Ubuntu:22.04:LTS

    Versiones
    • 3.0.2-5ubuntu1
    • 3.0.2-7
    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.0.2-7ubuntu2

    Actualiza a 3.0.2-7ubuntu2

Fuentes originales

Comprueba tu servidor →