p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de ruby2.5

Vulnerabilidades publicadas para ruby2.5 en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 25

  1. CVE-2023-28756

    Media · CVSS 5.3EPSS 2,45%Corrección disponible

    CVE-2023-28756

    A ReDoS issue was discovered in the Time component through 0.2.1 in Ruby through 3.2.1. The Time parser mishandles invalid URLs that have specific characters. It causes an increase in execution time for parsing strings to Time objects. The fixed versions are 0.1.1 and 0.2.2.

    • Actualiza a 2.5.1-1ubuntu1.16
    Publicación Actualización
  2. CVE-2023-28755

    Media · CVSS 5.3EPSS 2,64%Corrección disponible

    CVE-2023-28755

    A ReDoS issue was discovered in the URI component through 0.12.0 in Ruby through 3.2.1. The URI parser mishandles invalid URLs that have specific characters. It causes an increase in execution time for parsing strings to URI objects. The fixed versions are 0.12.1, 0.11.1, 0.10.2 and 0.10.0.1.

    • Actualiza a 2.5.1-1ubuntu1.16
    Publicación Actualización
  3. CVE-2021-33621

    Alta · CVSS 8.8EPSS 2,45%Corrección disponible

    CVE-2021-33621

    The cgi gem before 0.1.0.2, 0.2.x before 0.2.2, and 0.3.x before 0.3.5 for Ruby allows HTTP response splitting. This is relevant to applications that use untrusted user input either to generate an HTTP response or to create a CGI::Cookie object.

    • Actualiza a 2.5.1-1ubuntu1.13
    Publicación Actualización
  4. CVE-2021-32066

    Alta · CVSS 7.4EPSS 2,91%Corrección disponible

    CVE-2021-32066

    An issue was discovered in Ruby through 2.6.7, 2.7.x through 2.7.3, and 3.x through 3.0.1. Net::IMAP does not raise an exception when StartTLS fails with an an unknown response, which might allow man-in-the-middle attackers to bypass the TLS protections by leveraging a network position between the client and the registry to block the StartTLS command, aka a "StartTLS stripping attack."

    • Actualiza a 2.5.1-1ubuntu1.10
    Publicación Actualización
  5. CVE-2021-31810

    Media · CVSS 5.8EPSS 3,05%Corrección disponible

    CVE-2021-31810

    An issue was discovered in Ruby through 2.6.7, 2.7.x through 2.7.3, and 3.x through 3.0.1. A malicious FTP server can use the PASV response to trick Net::FTP into connecting back to a given IP address and port. This potentially makes curl extract information about services that are otherwise private and not disclosed (e.g., the attacker can conduct port scans and service banner extractions).

    • Actualiza a 2.5.1-1ubuntu1.10
    Publicación Actualización
  6. CVE-2020-25613

    Alta · CVSS 7.5EPSS 3,82%Corrección disponible

    CVE-2020-25613

    An issue was discovered in Ruby through 2.5.8, 2.6.x through 2.6.6, and 2.7.x through 2.7.1. WEBrick, a simple HTTP server bundled with Ruby, had not checked the transfer-encoding header value rigorously. An attacker may potentially exploit this issue to bypass a reverse proxy (which also has a poor header check), which may lead to an HTTP Request Smuggling attack.

    • Actualiza a 2.5.1-1ubuntu1.8
    Publicación Actualización
  7. CVE-2020-10933

    Media · CVSS 5.3EPSS 2,53%Corrección disponible

    CVE-2020-10933

    An issue was discovered in Ruby 2.5.x through 2.5.7, 2.6.x through 2.6.5, and 2.7.0. If a victim calls BasicSocket#read_nonblock(requested_size, buffer, exception: false), the method resizes the buffer to fit the requested size, but no data is copied. Thus, the buffer string provides the previous value of the heap. This may expose possibly sensitive data from the interpreter.

    • Actualiza a 2.5.1-1ubuntu1.8
    Publicación Actualización
  8. CVE-2020-10663

    Alta · CVSS 7.5EPSS 6,81%Corrección disponible

    CVE-2020-10663

    The JSON gem through 2.2.0 for Ruby, as used in Ruby 2.4 through 2.4.9, 2.5 through 2.5.7, and 2.6 through 2.6.5, has an Unsafe Object Creation Vulnerability. This is quite similar to CVE-2013-0269, but does not rely on poor garbage-collection behavior within Ruby. Specifically, use of JSON parsing methods can lead to creation of a malicious object within the interpreter, with adverse effects that are application-dependent.

    • Actualiza a 2.5.1-1ubuntu1.8
    Publicación Actualización
  9. CVE-2019-16255

    Alta · CVSS 8.1EPSS 4,19%Corrección disponible

    CVE-2019-16255

    Ruby through 2.4.7, 2.5.x through 2.5.6, and 2.6.x through 2.6.4 allows code injection if the first argument (aka the "command" argument) to Shell#[] or Shell#test in lib/shell.rb is untrusted data. An attacker can exploit this to call an arbitrary Ruby method.

    • Actualiza a 2.5.1-1ubuntu1.6
    Publicación Actualización
  10. CVE-2019-16254

    Media · CVSS 5.3EPSS 4,57%Corrección disponible

    CVE-2019-16254

    Ruby through 2.4.7, 2.5.x through 2.5.6, and 2.6.x through 2.6.4 allows HTTP Response Splitting. If a program using WEBrick inserts untrusted input into the response header, an attacker can exploit it to insert a newline character to split a header, and inject malicious content to deceive clients. NOTE: this issue exists because of an incomplete fix for CVE-2017-17742, which addressed the CRLF vector, but did not address an isolated CR or an isolated LF.

    • Actualiza a 2.5.1-1ubuntu1.6
    Publicación Actualización
  11. CVE-2019-16201

    Alta · CVSS 7.5EPSS 5,09%Corrección disponible

    CVE-2019-16201

    WEBrick::HTTPAuth::DigestAuth in Ruby through 2.4.7, 2.5.x through 2.5.6, and 2.6.x through 2.6.4 has a regular expression Denial of Service cause by looping/backtracking. A victim must expose a WEBrick server that uses DigestAuth to the Internet or a untrusted network.

    • Actualiza a 2.5.1-1ubuntu1.6
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →