CVE-2021-43008
CVE-2021-43008
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Improper Access Control in Adminer versions 1.12.0 to 4.6.2 (fixed in version 4.6.3) allows an attacker to achieve Arbitrary File Read on the remote server by requesting the Adminer to connect to a remote MySQL database.
CVSS 7.5 · Alta · EPSS 13,6% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · php
Productos y versiones afectados
n/a
- Versiones
- n/a: Afectada
Sin corrección publicada
adminer Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 4.6.3-1
Actualiza a 4.6.3-1
adminer Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 4.6.3-1
Actualiza a 4.6.3-1
adminer Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 4.6.3-1
Actualiza a 4.6.3-1
vrana/adminer Packagist
- Versiones
- v4.2.0
- v4.2.1
- v4.2.2
- v4.2.3
- v4.2.4
- v4.2.5
- v4.3.0
- v4.3.1
- v4.4.0
- v4.5.0
- v4.6.0
- v4.6.1
- v4.6.2
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 1.12.0, < 4.6.3
Actualiza a 4.6.3
adminer Ubuntu:Pro:16.04:LTS
- Versiones
- 4.2.1-1
- 4.2.1-1ubuntu1
- 4.2.1-1ubuntu1+esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
adminer Ubuntu:Pro:18.04:LTS
- Versiones
- 4.3.1-2
- 4.5.0-1
- 4.6.1-1
- 4.6.2-1
- 4.6.2-1ubuntu0.1~esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
adminer Ubuntu:Pro:20.04:LTS
- Versiones
- 4.7.2-1
- 4.7.4-1
- 4.7.5-1
- 4.7.6-1
- 4.7.6-1ubuntu0.1~esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
adminer Ubuntu:22.04:LTS
- Versiones
- 4.7.9-2
- 4.8.1-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
adminer Ubuntu:24.04:LTS
- Versiones
- 4.8.1-1
- 4.8.1-1ubuntu1
- 4.8.1-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
adminer Ubuntu:25.10
- Versiones
- 4.8.1-4
- 5.2.1+dfsg-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
adminer Ubuntu:26.10
- Versiones
- 5.4.1+dfsg-1
- 5.4.2+dfsg-1
- 5.4.4+dfsg-1
- 6.0.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
adminer Ubuntu:26.04:LTS
- Versiones
- 5.2.1+dfsg-1
- 5.3.0+dfsg-1
- 5.4.0+dfsg-1
- 5.4.1+dfsg-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/vrana/adminer/releases/tag/v4.6.3
- https://www.adminer.org/
- https://sansec.io/research/adminer-4.6.2-file-disclosure-vulnerability
- https://podalirius.net/en/cves/2021-43008/
- https://lists.debian.org/debian-lts-announce/2022/05/msg00012.html
- https://nvd.nist.gov/vuln/detail/CVE-2021-43008