CVE-2022-21697
CVE-2022-21697 · SSRF vulnerability (requires authentication)
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Jupyter Server Proxy is a Jupyter notebook server extension to proxy web services. Versions of Jupyter Server Proxy prior to 3.2.1 are vulnerable to Server-Side Request Forgery (SSRF). Any user deploying Jupyter Server or Notebook with jupyter-proxy-server extension enabled is affected. A lack of input validation allows authenticated clients to proxy requests to other hosts, bypassing the `allowed_hosts` check. Because authentication is required, which already grants permissions to make the same requests via kernel or terminal execution, this is considered low to moderate severity. Users may upgrade to version 3.2.1 to receive a patch or, as a workaround, install the patch manually.
CVSS 6.3 · Media · EPSS 1,1% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: python
Productos y versiones afectados
jupyter-server-proxy
- Versiones
- < 3.2.1: Afectada
Sin corrección publicada
jupyter-server-proxy PyPI
- Versiones
- 1.0
- 1.0.1
- 1.0b1
- 1.0b2
- 1.0b4
- 1.0b5
- 1.0b6
- 1.0b7
- 1.0b8
- 1.0b9
- 1.1.0
- 1.2.0
- 1.3.0
- 1.3.1
- 1.3.2
- 1.4.0
- 1.5.0
- 1.5.2
- 1.5.3
- 1.6.0
- 3.0.0
- 3.0.0rc1
- 3.0.1
- 3.0.2
- 3.1.0
- 3.2.0
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.2.1
Actualiza a 3.2.1
jupyter-server-proxy PyPI
- Versiones
- 1.0
- 1.0.1
- 1.0b1
- 1.0b2
- 1.0b4
- 1.0b5
- 1.0b6
- 1.0b7
- 1.0b8
- 1.0b9
- 1.1.0
- 1.2.0
- 1.3.0
- 1.3.1
- 1.3.2
- 1.4.0
- 1.5.0
- 1.5.2
- 1.5.3
- 1.6.0
- 3.0.0
- 3.0.0rc1
- 3.0.1
- 3.0.2
- 3.1.0
- 3.2.0
- Intervalos de versiones afectados
- GIT: < fd31930bacd12188c448c886e0783529436b99eb
- ECOSYSTEM: < 3.2.1
Actualiza a 3.2.1
Fuentes originales
- https://github.com/jupyterhub/jupyter-server-proxy/security/advisories/GHSA-gcv9-6737-pjqw
- https://github.com/jupyterhub/jupyter-server-proxy/commit/fd31930bacd12188c448c886e0783529436b99eb
- https://github.com/jupyterhub/jupyter-server-proxy/compare/v3.2.0...v3.2.1.patch
- https://nvd.nist.gov/vuln/detail/CVE-2022-21697