p PatchFirst

PatchFirst · Vulnerabilidades recientes

Vulnerabilidades de jupyter-server-proxy

Vulnerabilidades publicadas para jupyter-server-proxy en los últimos 30 días: 0. Incluidas en el catálogo KEV: 0.

Filtrar vulnerabilidades
Borrar filtros

Vulnerabilidades: 3

  1. CVE-2024-35225

    Crítica · CVSS 9.7EPSS 0,45%Corrección disponible

    Jupyter Server Proxy has a reflected XSS issue in host parameter

    Jupyter Server Proxy allows users to run arbitrary external processes alongside their notebook server and provide authenticated web access to them. Versions of 3.x prior to 3.2.4 and 4.x prior to 4.2.0 have a reflected cross-site scripting (XSS) issue. The `/proxy` endpoint accepts a `host` path segment in the format `/proxy/<host>`. When this endpoint is called with an invalid `host` value, `jupyter-server-proxy` replies with a response that includes the value of `host`, without sanitization [2]. A third-party actor can leverage this by sending a phishing link with an invalid `host` value containing custom JavaScript to a user. When the user

    • Actualiza a 3.2.4
    • Actualiza a 4.2.0
    Publicación Actualización
  2. CVE-2024-28179

    Crítica · CVSS 9.1EPSS 1,03%Corrección disponible

    Jupyter Server Proxy's Websocket Proxying does not require authentication

    Jupyter Server Proxy allows users to run arbitrary external processes alongside their Jupyter notebook servers and provides authenticated web access. Prior to versions 3.2.3 and 4.1.1, Jupyter Server Proxy did not check user authentication appropriately when proxying websockets, allowing unauthenticated access to anyone who had network access to the Jupyter server endpoint. This vulnerability can allow unauthenticated remote access to any websocket endpoint set up to be accessible via Jupyter Server Proxy. In many cases, this leads to remote unauthenticated arbitrary code execution, due to how affected instances use websockets. The websocket

    • Actualiza a 3.2.3
    • Actualiza a 4.1.1
    Publicación Actualización
  3. CVE-2022-21697

    Media · CVSS 6.3EPSS 1,1%Corrección disponible

    SSRF vulnerability (requires authentication)

    Jupyter Server Proxy is a Jupyter notebook server extension to proxy web services. Versions of Jupyter Server Proxy prior to 3.2.1 are vulnerable to Server-Side Request Forgery (SSRF). Any user deploying Jupyter Server or Notebook with jupyter-proxy-server extension enabled is affected. A lack of input validation allows authenticated clients to proxy requests to other hosts, bypassing the `allowed_hosts` check. Because authentication is required, which already grants permissions to make the same requests via kernel or terminal execution, this is considered low to moderate severity. Users may upgrade to version 3.2.1 to receive a patch or, as

    • Actualiza a 3.2.1
    Publicación Actualización

Comprueba tu servidor

Compara tu pila y las versiones instaladas con las bases actuales de vulnerabilidades.

Comprueba tu servidor →