CVE-2022-23633
CVE-2022-23633 · Exposure of sensitive information in Action Pack
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Action Pack is a framework for handling and responding to web requests. Under certain circumstances response bodies will not be closed. In the event a response is *not* notified of a `close`, `ActionDispatch::Executor` will not know to reset thread local state for the next request. This can lead to data being leaked to subsequent requests.This has been fixed in Rails 7.0.2.1, 6.1.4.5, 6.0.4.5, and 5.2.6.1. Upgrading is highly recommended, but to work around this problem a middleware described in GHSA-wh98-p28r-vrc9 can be used.
CVSS 7.4 · Alta · EPSS 2,2% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
rails
- Versiones
- >= 7.0.0.0, < 7.0.2.1: Afectada
- >= 6.1.0.0, < 6.1.4.5: Afectada
- >= 6.0.0.0, < 6.0.4.5: Afectada
- >= 5.0.0, < 5.2.6.1: Afectada
Sin corrección publicada
rails Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 2:6.1.4.6+dfsg-1
Actualiza a 2:6.1.4.6+dfsg-1
rails Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 2:6.1.4.6+dfsg-1
Actualiza a 2:6.1.4.6+dfsg-1
rails Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 2:6.1.4.6+dfsg-1
Actualiza a 2:6.1.4.6+dfsg-1
rails Ubuntu:Pro:16.04:LTS
- Versiones
- 2:4.1.10-1
- 2:4.2.5-1
- 2:4.2.5.1-1
- 2:4.2.5.2-2
- 2:4.2.6-1
- 2:4.2.6-1ubuntu0.1~esm1
- 2:4.2.6-1ubuntu0.1~esm2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
rails Ubuntu:Pro:18.04:LTS
- Versiones
- 2:4.2.9-2
- 2:4.2.9-4
- 2:4.2.10-0ubuntu4
- 2:4.2.10-0ubuntu4+esm1
- 2:4.2.10-0ubuntu4+esm2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
rails Ubuntu:Pro:20.04:LTS
- Versiones
- 2:5.2.2.1+dfsg-1ubuntu1
- 2:5.2.3+dfsg-3
- 2:5.2.3+dfsg-3ubuntu0.1~esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
rails Ubuntu:Pro:22.04:LTS
- Versiones
- 2:6.0.3.7+dfsg-2
- 2:6.1.4.1+dfsg-8ubuntu2
- 2:6.1.4.1+dfsg-8ubuntu2+esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
rails Ubuntu:24.04:LTS
- Versiones
- 2:6.1.7.3+dfsg-2build1
- 2:6.1.7.3+dfsg-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
rails Ubuntu:25.10
- Versiones
- 2:6.1.7.3+dfsg-7
- 2:7.2.2.1+dfsg-7
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
rails Ubuntu:26.10
- Versiones
- 2:7.2.3+dfsg-2
- 2:7.2.3.2+dfsg-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
rails Ubuntu:26.04:LTS
- Versiones
- 2:7.2.2.1+dfsg-7
- 2:7.2.2.2+dfsg-2
- 2:7.2.3+dfsg-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/rails/rails/security/advisories/GHSA-wh98-p28r-vrc9
- https://github.com/rails/rails/commit/f9a2ad03943d5c2ba54e1d45f155442b519c75da
- http://www.openwall.com/lists/oss-security/2022/02/11/5
- https://lists.debian.org/debian-lts-announce/2022/09/msg00002.html
- https://www.debian.org/security/2023/dsa-5372
- https://security.netapp.com/advisory/ntap-20240119-0013/
- https://nvd.nist.gov/vuln/detail/CVE-2022-23633