CVE-2022-23633
CVE-2022-23633 · Exposure of sensitive information in Action Pack
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Action Pack is a framework for handling and responding to web requests. Under certain circumstances response bodies will not be closed. In the event a response is *not* notified of a `close`, `ActionDispatch::Executor` will not know to reset thread local state for the next request. This can lead to data being leaked to subsequent requests.This has been fixed in Rails 7.0.2.1, 6.1.4.5, 6.0.4.5, and 5.2.6.1. Upgrading is highly recommended, but to work around this problem a middleware described in GHSA-wh98-p28r-vrc9 can be used.
CVSS 7.4 · Hoch · EPSS 2,2% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
rails
- Softwareversionen
- >= 7.0.0.0, < 7.0.2.1: Betroffen
- >= 6.1.0.0, < 6.1.4.5: Betroffen
- >= 6.0.0.0, < 6.0.4.5: Betroffen
- >= 5.0.0, < 5.2.6.1: Betroffen
Keine Korrektur veröffentlicht
rails Debian:12
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2:6.1.4.6+dfsg-1
Auf 2:6.1.4.6+dfsg-1 aktualisieren
rails Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2:6.1.4.6+dfsg-1
Auf 2:6.1.4.6+dfsg-1 aktualisieren
rails Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2:6.1.4.6+dfsg-1
Auf 2:6.1.4.6+dfsg-1 aktualisieren
rails Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 2:4.1.10-1
- 2:4.2.5-1
- 2:4.2.5.1-1
- 2:4.2.5.2-2
- 2:4.2.6-1
- 2:4.2.6-1ubuntu0.1~esm1
- 2:4.2.6-1ubuntu0.1~esm2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
rails Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 2:4.2.9-2
- 2:4.2.9-4
- 2:4.2.10-0ubuntu4
- 2:4.2.10-0ubuntu4+esm1
- 2:4.2.10-0ubuntu4+esm2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
rails Ubuntu:Pro:20.04:LTS
- Softwareversionen
- 2:5.2.2.1+dfsg-1ubuntu1
- 2:5.2.3+dfsg-3
- 2:5.2.3+dfsg-3ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
rails Ubuntu:Pro:22.04:LTS
- Softwareversionen
- 2:6.0.3.7+dfsg-2
- 2:6.1.4.1+dfsg-8ubuntu2
- 2:6.1.4.1+dfsg-8ubuntu2+esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
rails Ubuntu:24.04:LTS
- Softwareversionen
- 2:6.1.7.3+dfsg-2build1
- 2:6.1.7.3+dfsg-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
rails Ubuntu:25.10
- Softwareversionen
- 2:6.1.7.3+dfsg-7
- 2:7.2.2.1+dfsg-7
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
rails Ubuntu:26.10
- Softwareversionen
- 2:7.2.3+dfsg-2
- 2:7.2.3.2+dfsg-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
rails Ubuntu:26.04:LTS
- Softwareversionen
- 2:7.2.2.1+dfsg-7
- 2:7.2.2.2+dfsg-2
- 2:7.2.3+dfsg-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
Originalquellen
- https://github.com/rails/rails/security/advisories/GHSA-wh98-p28r-vrc9
- https://github.com/rails/rails/commit/f9a2ad03943d5c2ba54e1d45f155442b519c75da
- http://www.openwall.com/lists/oss-security/2022/02/11/5
- https://lists.debian.org/debian-lts-announce/2022/09/msg00002.html
- https://www.debian.org/security/2023/dsa-5372
- https://security.netapp.com/advisory/ntap-20240119-0013/
- https://nvd.nist.gov/vuln/detail/CVE-2022-23633