CVE-2022-23638
CVE-2022-23638 · Cross-site Scripting in svg-sanitizer
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
svg-sanitizer is a SVG/XML sanitizer written in PHP. A cross-site scripting vulnerability impacts all users of the `svg-sanitizer` library prior to version 0.15.0. This issue is fixed in version 0.15.0. There is currently no workaround available.
CVSS 6.2 · Media · EPSS 0,7% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · php
Productos y versiones afectados
svg-sanitizer
- Versiones
- < 0.15.0: Afectada
Sin corrección publicada
enshrined/svg-sanitize Packagist
- Versiones
- 0.1.0
- 0.1.1
- 0.1.2
- 0.1.3
- 0.1.4
- 0.1.5
- 0.1.6
- 0.10.0
- 0.11.0
- 0.12.0
- 0.13.0
- 0.13.1
- 0.13.2
- 0.13.3
- 0.14.0
- 0.14.1
- 0.2.0
- 0.2.1
- 0.3.0
- 0.4.0
- 0.4.1
- 0.5.0
- 0.5.1
- 0.5.2
- 0.5.3
- 0.5.3.1
- 0.6.0
- 0.7.0
- 0.7.1
- 0.7.2
- 0.8.0
- 0.8.1
- 0.8.2
- 0.9.0
- 0.9.1
- 0.9.2
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.15.0
Actualiza a 0.15.0
spip Ubuntu:22.04:LTS
- Versiones
- 3.2.11-3
- 3.2.12-1
- 4.0.2-1
- 4.0.4-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
spip Ubuntu:24.04:LTS
- Versiones
- 4.1.11+dfsg-1
- 4.1.12+dfsg-1
- 4.1.13+dfsg-1
- 4.1.15+dfsg-1
- 4.2.9+dfsg-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
spip Ubuntu:25.10
- Versiones
- 4.3.8+dfsg-1
- 4.4.3+dfsg-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
spip Ubuntu:26.10
- Versiones
- 4.4.9+dfsg-1
- 4.4.15+dfsg-1
- 4.4.16+dfsg-1
- 4.4.19+dfsg-1
- 4.4.20+dfsg-1
- 4.4.21+dfsg-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
spip Ubuntu:26.04:LTS
- Versiones
- 4.4.3+dfsg-1
- 4.4.6+dfsg-1
- 4.4.7+dfsg-1
- 4.4.8+dfsg-1
- 4.4.9+dfsg-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada