CVE-2022-23638
CVE-2022-23638 · Cross-site Scripting in svg-sanitizer
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
svg-sanitizer is a SVG/XML sanitizer written in PHP. A cross-site scripting vulnerability impacts all users of the `svg-sanitizer` library prior to version 0.15.0. This issue is fixed in version 0.15.0. There is currently no workaround available.
CVSS 6.2 · Moyenne · EPSS 0,7% · Correctif disponible
- Publication
- Mise à jour
Produits et versions concernés
svg-sanitizer
- Versions du logiciel
- < 0.15.0: Concernée
Aucun correctif publié
enshrined/svg-sanitize Packagist
- Versions du logiciel
- 0.1.0
- 0.1.1
- 0.1.2
- 0.1.3
- 0.1.4
- 0.1.5
- 0.1.6
- 0.10.0
- 0.11.0
- 0.12.0
- 0.13.0
- 0.13.1
- 0.13.2
- 0.13.3
- 0.14.0
- 0.14.1
- 0.2.0
- 0.2.1
- 0.3.0
- 0.4.0
- 0.4.1
- 0.5.0
- 0.5.1
- 0.5.2
- 0.5.3
- 0.5.3.1
- 0.6.0
- 0.7.0
- 0.7.1
- 0.7.2
- 0.8.0
- 0.8.1
- 0.8.2
- 0.9.0
- 0.9.1
- 0.9.2
- Plages de versions concernées
- ECOSYSTEM: < 0.15.0
Mettez à jour vers 0.15.0
spip Ubuntu:22.04:LTS
- Versions du logiciel
- 3.2.11-3
- 3.2.12-1
- 4.0.2-1
- 4.0.4-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
spip Ubuntu:24.04:LTS
- Versions du logiciel
- 4.1.11+dfsg-1
- 4.1.12+dfsg-1
- 4.1.13+dfsg-1
- 4.1.15+dfsg-1
- 4.2.9+dfsg-2
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
spip Ubuntu:25.10
- Versions du logiciel
- 4.3.8+dfsg-1
- 4.4.3+dfsg-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
spip Ubuntu:26.10
- Versions du logiciel
- 4.4.9+dfsg-1
- 4.4.15+dfsg-1
- 4.4.16+dfsg-1
- 4.4.19+dfsg-1
- 4.4.20+dfsg-1
- 4.4.21+dfsg-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
spip Ubuntu:26.04:LTS
- Versions du logiciel
- 4.4.3+dfsg-1
- 4.4.6+dfsg-1
- 4.4.7+dfsg-1
- 4.4.8+dfsg-1
- 4.4.9+dfsg-1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié