CVE-2022-29217
CVE-2022-29217 · Key confusion through non-blocklisted public key formats in PyJWT
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
PyJWT is a Python implementation of RFC 7519. PyJWT supports multiple different JWT signing algorithms. With JWT, an attacker submitting the JWT token can choose the used signing algorithm. The PyJWT library requires that the application chooses what algorithms are supported. The application can specify `jwt.algorithms.get_default_algorithms()` to get support for all algorithms, or specify a single algorithm. The issue is not that big as `algorithms=jwt.algorithms.get_default_algorithms()` has to be used. Users should upgrade to v2.4.0 to receive a patch for this issue. As a workaround, always be explicit with the algorithms that are accepted and expected when decoding.
CVSS 7.4 · Élevée · EPSS 1,4% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system · python
Produits et versions concernés
pyjwt
- Versions du logiciel
- >= 1.5.0, < 2.4.0: Concernée
Aucun correctif publié
pyjwt Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 2.4.0-1
Mettez à jour vers 2.4.0-1
pyjwt Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 2.4.0-1
Mettez à jour vers 2.4.0-1
pyjwt Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 2.4.0-1
Mettez à jour vers 2.4.0-1
pyjwt PyPI
- Versions du logiciel
- 1.5.0
- 1.5.1
- 1.5.2
- 1.5.3
- 1.6.0
- 1.6.1
- 1.6.3
- 1.6.4
- 1.7.0
- 1.7.1
- 2.0.0
- 2.0.0a1
- 2.0.0a2
- 2.0.1
- 2.1.0
- 2.2.0
- 2.3.0
- Plages de versions concernées
- ECOSYSTEM: ≥ 1.5.0, < 2.4.0
Mettez à jour vers 2.4.0
pyjwt PyPI
- Versions du logiciel
- 1.5.0
- 1.5.1
- 1.5.2
- 1.5.3
- 1.6.0
- 1.6.1
- 1.6.3
- 1.6.4
- 1.7.0
- 1.7.1
- 2.0.0
- 2.0.0a1
- 2.0.0a2
- 2.0.1
- 2.1.0
- 2.2.0
- 2.3.0
- Plages de versions concernées
- GIT: < 9c528670c455b8d948aff95ed50e22940d1ad3fc
- ECOSYSTEM: ≥ 1.5.0, < 2.4.0
Mettez à jour vers 2.4.0
pyjwt Ubuntu:18.04:LTS
- Versions du logiciel
- 1.4.2-1.1
- 1.5.3+ds1-1
- Plages de versions concernées
- ECOSYSTEM: < 1.5.3+ds1-1ubuntu0.1
Mettez à jour vers 1.5.3+ds1-1ubuntu0.1
pyjwt Ubuntu:20.04:LTS
- Versions du logiciel
- 1.7.0-2
- 1.7.1-1
- 1.7.1-2ubuntu1
- 1.7.1-2ubuntu2
- Plages de versions concernées
- ECOSYSTEM: < 1.7.1-2ubuntu2.1
Mettez à jour vers 1.7.1-2ubuntu2.1
pyjwt Ubuntu:22.04:LTS
- Versions du logiciel
- 1.7.1-2ubuntu2
- 2.1.0-1
- 2.3.0-1
- Plages de versions concernées
- ECOSYSTEM: < 2.3.0-1ubuntu0.1
Mettez à jour vers 2.3.0-1ubuntu0.1
Sources originales
- https://github.com/jpadilla/pyjwt/security/advisories/GHSA-ffqj-6fqr-9h24
- https://github.com/jpadilla/pyjwt/commit/9c528670c455b8d948aff95ed50e22940d1ad3fc
- https://github.com/jpadilla/pyjwt/releases/tag/2.4.0
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/6HIYEYZRQEP6QTHT3EHH3RGFYJIHIMAO/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/5PK7IQCBVNLYJEFTPHBBPFP72H4WUFNX/
- https://www.vicarius.io/vsociety/posts/risky-algorithms-algorithm-confusion-in-pyjwt-cve-2022-29217
- https://nvd.nist.gov/vuln/detail/CVE-2022-29217