CVE-2022-41881
CVE-2022-41881
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Netty project is an event-driven asynchronous network application framework. In versions prior to 4.1.86.Final, a StackOverflowError can be raised when parsing a malformed crafted message due to an infinite recursion. This issue is patched in version 4.1.86.Final. There is no workaround, except using a custom HaProxyMessageDecoder.
CVSS 5.3 · Media · EPSS 1,6% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
netty
- Versiones
- < 4.1.86.Final: Afectada
Sin corrección publicada
netty Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:4.1.48-6
Actualiza a 1:4.1.48-6
netty Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:4.1.48-6
Actualiza a 1:4.1.48-6
netty Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:4.1.48-6
Actualiza a 1:4.1.48-6
netty Ubuntu:Pro:14.04:LTS
- Versiones
- 1:3.2.6.Final-2
- 1:3.2.6.Final-2+deb8u2build0.14.04.1~esm1
- 1:3.2.6.Final-2+deb8u2ubuntu0.1~esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
netty Ubuntu:Pro:16.04:LTS
- Versiones
- 1:3.2.6.Final-2
- 1:4.0.32-1
- 1:4.0.33-1
- 1:4.0.34-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:4.0.34-1ubuntu0.1~esm1
Actualiza a 1:4.0.34-1ubuntu0.1~esm1
netty-3.9 Ubuntu:16.04:LTS
- Versiones
- 3.9.0.Final-1
- 3.9.0.Final-1ubuntu0.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
netty Ubuntu:Pro:18.04:LTS
- Versiones
- 1:4.1.7-4
- 1:4.1.7-4ubuntu0.1~esm1
- 1:4.1.7-4ubuntu0.1
- 1:4.1.7-4ubuntu0.1+esm1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:4.1.7-4ubuntu0.1+esm2
Actualiza a 1:4.1.7-4ubuntu0.1+esm2
netty-3.9 Ubuntu:18.04:LTS
- Versiones
- 3.9.9.Final-1
- 3.9.9.Final-1+deb9u1build0.18.04.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
netty Ubuntu:Pro:20.04:LTS
- Versiones
- 1:4.1.33-1
- 1:4.1.33-2
- 1:4.1.33-3
- 1:4.1.45-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:4.1.45-1ubuntu0.1~esm1
Actualiza a 1:4.1.45-1ubuntu0.1~esm1
netty Ubuntu:22.04:LTS
- Versiones
- 1:4.1.48-4
- Intervalos de versiones afectados
- ECOSYSTEM: < 1:4.1.48-4+deb11u1build0.22.04.1
Actualiza a 1:4.1.48-4+deb11u1build0.22.04.1