p PatchFirst

CVE-2022-41881

CVE-2022-41881

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Netty project is an event-driven asynchronous network application framework. In versions prior to 4.1.86.Final, a StackOverflowError can be raised when parsing a malformed crafted message due to an infinite recursion. This issue is patched in version 4.1.86.Final. There is no workaround, except using a custom HaProxyMessageDecoder.

CVSS 5.3 · Mittel · EPSS 1,6% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • netty

    Softwareversionen
    • < 4.1.86.Final: Betroffen

    Keine Korrektur veröffentlicht

  • netty Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1:4.1.48-6

    Auf 1:4.1.48-6 aktualisieren

  • netty Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1:4.1.48-6

    Auf 1:4.1.48-6 aktualisieren

  • netty Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1:4.1.48-6

    Auf 1:4.1.48-6 aktualisieren

  • netty Ubuntu:Pro:14.04:LTS

    Softwareversionen
    • 1:3.2.6.Final-2
    • 1:3.2.6.Final-2+deb8u2build0.14.04.1~esm1
    • 1:3.2.6.Final-2+deb8u2ubuntu0.1~esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • netty Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 1:3.2.6.Final-2
    • 1:4.0.32-1
    • 1:4.0.33-1
    • 1:4.0.34-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1:4.0.34-1ubuntu0.1~esm1

    Auf 1:4.0.34-1ubuntu0.1~esm1 aktualisieren

  • netty-3.9 Ubuntu:16.04:LTS

    Softwareversionen
    • 3.9.0.Final-1
    • 3.9.0.Final-1ubuntu0.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • netty Ubuntu:Pro:18.04:LTS

    Softwareversionen
    • 1:4.1.7-4
    • 1:4.1.7-4ubuntu0.1~esm1
    • 1:4.1.7-4ubuntu0.1
    • 1:4.1.7-4ubuntu0.1+esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1:4.1.7-4ubuntu0.1+esm2

    Auf 1:4.1.7-4ubuntu0.1+esm2 aktualisieren

  • netty-3.9 Ubuntu:18.04:LTS

    Softwareversionen
    • 3.9.9.Final-1
    • 3.9.9.Final-1+deb9u1build0.18.04.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • netty Ubuntu:Pro:20.04:LTS

    Softwareversionen
    • 1:4.1.33-1
    • 1:4.1.33-2
    • 1:4.1.33-3
    • 1:4.1.45-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1:4.1.45-1ubuntu0.1~esm1

    Auf 1:4.1.45-1ubuntu0.1~esm1 aktualisieren

  • netty Ubuntu:22.04:LTS

    Softwareversionen
    • 1:4.1.48-4
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1:4.1.48-4+deb11u1build0.22.04.1

    Auf 1:4.1.48-4+deb11u1build0.22.04.1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →