CVE-2022-41916
CVE-2022-41916 · Read one byte past a buffer when normalizing Unicode
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Heimdal is an implementation of ASN.1/DER, PKIX, and Kerberos. Versions prior to 7.7.1 are vulnerable to a denial of service vulnerability in Heimdal's PKI certificate validation library, affecting the KDC (via PKINIT) and kinit (via PKINIT), as well as any third-party applications using Heimdal's libhx509. Users should upgrade to Heimdal 7.7.1 or 7.8. There are no known workarounds for this issue.
CVSS 5.9 · Media · EPSS 1,0% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
heimdal
- Versiones
- < 7.7.1: Afectada
Sin corrección publicada
heimdal Debian:12
- Intervalos de versiones afectados
- ECOSYSTEM: < 7.8.git20221115.a6cf945+dfsg-1
Actualiza a 7.8.git20221115.a6cf945+dfsg-1
heimdal Debian:13
- Intervalos de versiones afectados
- ECOSYSTEM: < 7.8.git20221115.a6cf945+dfsg-1
Actualiza a 7.8.git20221115.a6cf945+dfsg-1
heimdal Debian:14
- Intervalos de versiones afectados
- ECOSYSTEM: < 7.8.git20221115.a6cf945+dfsg-1
Actualiza a 7.8.git20221115.a6cf945+dfsg-1
heimdal Ubuntu:Pro:14.04:LTS
- Versiones
- 1.6~git20120403+dfsg1-3ubuntu0.1
- 1.6~git20120403+dfsg1-3ubuntu0.2
- 1.6~git20131207+dfsg-1ubuntu1
- 1.6~git20131207+dfsg-1ubuntu1.1
- 1.6~git20131207+dfsg-1ubuntu1.2
- 1.6~git20131207+dfsg-1ubuntu1.2+esm1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.6~git20131207+dfsg-1ubuntu1.2+esm2
Actualiza a 1.6~git20131207+dfsg-1ubuntu1.2+esm2
heimdal Ubuntu:Pro:16.04:LTS
- Versiones
- 1.6~rc2+dfsg-10ubuntu1
- 1.7~git20150920+dfsg-4ubuntu1
- 1.7~git20150920+dfsg-4ubuntu1.16.04.1
- 1.7~git20150920+dfsg-4ubuntu1.16.04.1+esm1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.7~git20150920+dfsg-4ubuntu1.16.04.1+esm2
Actualiza a 1.7~git20150920+dfsg-4ubuntu1.16.04.1+esm2
heimdal Ubuntu:18.04:LTS
- Versiones
- 7.4.0.dfsg.1-2
- 7.5.0+dfsg-1
- 7.5.0+dfsg-1ubuntu0.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 7.5.0+dfsg-1ubuntu0.2
Actualiza a 7.5.0+dfsg-1ubuntu0.2
heimdal Ubuntu:20.04:LTS
- Versiones
- 7.5.0+dfsg-3build1
- 7.7.0+dfsg-1
- 7.7.0+dfsg-1ubuntu1
- 7.7.0+dfsg-1ubuntu1.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 7.7.0+dfsg-1ubuntu1.2
Actualiza a 7.7.0+dfsg-1ubuntu1.2
heimdal Ubuntu:22.04:LTS
- Versiones
- 7.7.0+dfsg-2ubuntu2
- 7.7.0+dfsg-3ubuntu1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
heimdal Ubuntu:24.04:LTS
- Versiones
- 7.8.git20221117.28daf24+dfsg-3ubuntu1
- 7.8.git20221117.28daf24+dfsg-3ubuntu2
- 7.8.git20221117.28daf24+dfsg-3ubuntu3
- 7.8.git20221117.28daf24+dfsg-3ubuntu4
- 7.8.git20221117.28daf24+dfsg-4ubuntu1
- 7.8.git20221117.28daf24+dfsg-5ubuntu2
- 7.8.git20221117.28daf24+dfsg-5ubuntu3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
heimdal Ubuntu:25.10
- Versiones
- 7.8.git20221117.28daf24+dfsg-9ubuntu1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
heimdal Ubuntu:26.10
- Versiones
- 7.8.git20221117.28daf24+dfsg-11ubuntu1
- 7.8.git20221117.28daf24+dfsg-12ubuntu1
- 7.8.git20240113.1b4565a+dfsg-1ubuntu1
- 7.8.git20240113.1b4565a+dfsg-1ubuntu2
- 7.8.git20240113.1b4565a+dfsg-2ubuntu1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
heimdal Ubuntu:26.04:LTS
- Versiones
- 7.8.git20221117.28daf24+dfsg-9ubuntu1
- 7.8.git20221117.28daf24+dfsg-10ubuntu1
- 7.8.git20221117.28daf24+dfsg-11ubuntu1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/heimdal/heimdal/security/advisories/GHSA-mgqr-gvh6-23cx
- https://www.debian.org/security/2022/dsa-5287
- https://lists.debian.org/debian-lts-announce/2022/11/msg00034.html
- https://security.netapp.com/advisory/ntap-20230216-0008/
- https://security.gentoo.org/glsa/202310-06
- https://nvd.nist.gov/vuln/detail/CVE-2022-41916