CVE-2022-41916
CVE-2022-41916 · Read one byte past a buffer when normalizing Unicode
Cette page présente des faits issus de sources publiques. Consultez l’avis original avant toute mise à jour.
Heimdal is an implementation of ASN.1/DER, PKIX, and Kerberos. Versions prior to 7.7.1 are vulnerable to a denial of service vulnerability in Heimdal's PKI certificate validation library, affecting the KDC (via PKINIT) and kinit (via PKINIT), as well as any third-party applications using Heimdal's libhx509. Users should upgrade to Heimdal 7.7.1 or 7.8. There are no known workarounds for this issue.
CVSS 5.9 · Moyenne · EPSS 1,0% · Correctif disponible
- Publication
- Mise à jour
Pile logicielle: system
Produits et versions concernés
heimdal
- Versions du logiciel
- < 7.7.1: Concernée
Aucun correctif publié
heimdal Debian:12
- Plages de versions concernées
- ECOSYSTEM: < 7.8.git20221115.a6cf945+dfsg-1
Mettez à jour vers 7.8.git20221115.a6cf945+dfsg-1
heimdal Debian:13
- Plages de versions concernées
- ECOSYSTEM: < 7.8.git20221115.a6cf945+dfsg-1
Mettez à jour vers 7.8.git20221115.a6cf945+dfsg-1
heimdal Debian:14
- Plages de versions concernées
- ECOSYSTEM: < 7.8.git20221115.a6cf945+dfsg-1
Mettez à jour vers 7.8.git20221115.a6cf945+dfsg-1
heimdal Ubuntu:Pro:14.04:LTS
- Versions du logiciel
- 1.6~git20120403+dfsg1-3ubuntu0.1
- 1.6~git20120403+dfsg1-3ubuntu0.2
- 1.6~git20131207+dfsg-1ubuntu1
- 1.6~git20131207+dfsg-1ubuntu1.1
- 1.6~git20131207+dfsg-1ubuntu1.2
- 1.6~git20131207+dfsg-1ubuntu1.2+esm1
- Plages de versions concernées
- ECOSYSTEM: < 1.6~git20131207+dfsg-1ubuntu1.2+esm2
Mettez à jour vers 1.6~git20131207+dfsg-1ubuntu1.2+esm2
heimdal Ubuntu:Pro:16.04:LTS
- Versions du logiciel
- 1.6~rc2+dfsg-10ubuntu1
- 1.7~git20150920+dfsg-4ubuntu1
- 1.7~git20150920+dfsg-4ubuntu1.16.04.1
- 1.7~git20150920+dfsg-4ubuntu1.16.04.1+esm1
- Plages de versions concernées
- ECOSYSTEM: < 1.7~git20150920+dfsg-4ubuntu1.16.04.1+esm2
Mettez à jour vers 1.7~git20150920+dfsg-4ubuntu1.16.04.1+esm2
heimdal Ubuntu:18.04:LTS
- Versions du logiciel
- 7.4.0.dfsg.1-2
- 7.5.0+dfsg-1
- 7.5.0+dfsg-1ubuntu0.1
- Plages de versions concernées
- ECOSYSTEM: < 7.5.0+dfsg-1ubuntu0.2
Mettez à jour vers 7.5.0+dfsg-1ubuntu0.2
heimdal Ubuntu:20.04:LTS
- Versions du logiciel
- 7.5.0+dfsg-3build1
- 7.7.0+dfsg-1
- 7.7.0+dfsg-1ubuntu1
- 7.7.0+dfsg-1ubuntu1.1
- Plages de versions concernées
- ECOSYSTEM: < 7.7.0+dfsg-1ubuntu1.2
Mettez à jour vers 7.7.0+dfsg-1ubuntu1.2
heimdal Ubuntu:22.04:LTS
- Versions du logiciel
- 7.7.0+dfsg-2ubuntu2
- 7.7.0+dfsg-3ubuntu1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
heimdal Ubuntu:24.04:LTS
- Versions du logiciel
- 7.8.git20221117.28daf24+dfsg-3ubuntu1
- 7.8.git20221117.28daf24+dfsg-3ubuntu2
- 7.8.git20221117.28daf24+dfsg-3ubuntu3
- 7.8.git20221117.28daf24+dfsg-3ubuntu4
- 7.8.git20221117.28daf24+dfsg-4ubuntu1
- 7.8.git20221117.28daf24+dfsg-5ubuntu2
- 7.8.git20221117.28daf24+dfsg-5ubuntu3
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
heimdal Ubuntu:25.10
- Versions du logiciel
- 7.8.git20221117.28daf24+dfsg-9ubuntu1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
heimdal Ubuntu:26.10
- Versions du logiciel
- 7.8.git20221117.28daf24+dfsg-11ubuntu1
- 7.8.git20221117.28daf24+dfsg-12ubuntu1
- 7.8.git20240113.1b4565a+dfsg-1ubuntu1
- 7.8.git20240113.1b4565a+dfsg-1ubuntu2
- 7.8.git20240113.1b4565a+dfsg-2ubuntu1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
heimdal Ubuntu:26.04:LTS
- Versions du logiciel
- 7.8.git20221117.28daf24+dfsg-9ubuntu1
- 7.8.git20221117.28daf24+dfsg-10ubuntu1
- 7.8.git20221117.28daf24+dfsg-11ubuntu1
- Plages de versions concernées
- ECOSYSTEM: (−∞, +∞)
Aucun correctif publié
Sources originales
- https://github.com/heimdal/heimdal/security/advisories/GHSA-mgqr-gvh6-23cx
- https://www.debian.org/security/2022/dsa-5287
- https://lists.debian.org/debian-lts-announce/2022/11/msg00034.html
- https://security.netapp.com/advisory/ntap-20230216-0008/
- https://security.gentoo.org/glsa/202310-06
- https://nvd.nist.gov/vuln/detail/CVE-2022-41916