p PatchFirst

CVE-2022-43766

CVE-2022-43766 · Apache IoTDB prior to 0.13.3 allows DoS

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Apache IoTDB version 0.12.2 to 0.12.6, 0.13.0 to 0.13.2 are vulnerable to a Denial of Service attack when accepting untrusted patterns for REGEXP queries with Java 8. Users should upgrade to 0.13.3 which addresses this issue or use a later version of Java to avoid it.

CVSS 7.5 · Alta · EPSS 1,6% · Corrección disponible

Publicación
Actualización

Pila tecnológica: python

Productos y versiones afectados

  • apache iotdb

    Versiones
    • ≥ unspecified, ≤ 0.13.2: Afectada (custom)
    • ≥ 0.12.2, < unspecified: Afectada (custom)

    Sin corrección publicada

  • org.apache.iotdb:flink-tsfile-connector Maven

    Versiones
    • 0.12.2
    • 0.12.3
    • 0.12.4
    • 0.12.5
    • 0.12.6
    • 0.13.0
    • 0.13.1
    • 0.13.2
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 0.12.2, < 0.13.3

    Actualiza a 0.13.3

  • apache-iotdb PyPI

    Versiones
    • 0.12.2
    • 0.12.3
    • 0.12.4
    • 0.12.5
    • 0.12.6
    • 0.13.0
    • 0.13.0.post1
    • 0.13.1
    • 0.13.2
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 0.12.2, < 0.13.3

    Actualiza a 0.13.3

  • org.apache.iotdb:iotdb-server Maven

    Versiones
    • 0.12.2
    • 0.12.3
    • 0.12.4
    • 0.12.5
    • 0.12.6
    • 0.13.0
    • 0.13.1
    • 0.13.2
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 0.12.2, < 0.13.3

    Actualiza a 0.13.3

  • org.apache.iotdb:tsfile Maven

    Versiones
    • 0.12.2
    • 0.12.3
    • 0.12.4
    • 0.12.5
    • 0.12.6
    • 0.13.0
    • 0.13.1
    • 0.13.2
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 0.12.2, < 0.13.3

    Actualiza a 0.13.3

Fuentes originales

Comprueba tu servidor →