p PatchFirst

CVE-2022-43766

CVE-2022-43766 · Apache IoTDB prior to 0.13.3 allows DoS

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Apache IoTDB version 0.12.2 to 0.12.6, 0.13.0 to 0.13.2 are vulnerable to a Denial of Service attack when accepting untrusted patterns for REGEXP queries with Java 8. Users should upgrade to 0.13.3 which addresses this issue or use a later version of Java to avoid it.

CVSS 7.5 · Hoch · EPSS 1,6% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: python

Betroffene Produkte und Versionen

  • apache iotdb

    Softwareversionen
    • ≥ unspecified, ≤ 0.13.2: Betroffen (custom)
    • ≥ 0.12.2, < unspecified: Betroffen (custom)

    Keine Korrektur veröffentlicht

  • org.apache.iotdb:flink-tsfile-connector Maven

    Softwareversionen
    • 0.12.2
    • 0.12.3
    • 0.12.4
    • 0.12.5
    • 0.12.6
    • 0.13.0
    • 0.13.1
    • 0.13.2
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 0.12.2, < 0.13.3

    Auf 0.13.3 aktualisieren

  • apache-iotdb PyPI

    Softwareversionen
    • 0.12.2
    • 0.12.3
    • 0.12.4
    • 0.12.5
    • 0.12.6
    • 0.13.0
    • 0.13.0.post1
    • 0.13.1
    • 0.13.2
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 0.12.2, < 0.13.3

    Auf 0.13.3 aktualisieren

  • org.apache.iotdb:iotdb-server Maven

    Softwareversionen
    • 0.12.2
    • 0.12.3
    • 0.12.4
    • 0.12.5
    • 0.12.6
    • 0.13.0
    • 0.13.1
    • 0.13.2
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 0.12.2, < 0.13.3

    Auf 0.13.3 aktualisieren

  • org.apache.iotdb:tsfile Maven

    Softwareversionen
    • 0.12.2
    • 0.12.3
    • 0.12.4
    • 0.12.5
    • 0.12.6
    • 0.13.0
    • 0.13.1
    • 0.13.2
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 0.12.2, < 0.13.3

    Auf 0.13.3 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →